Exported JPG much darker than darkroom view

There was a question like this back in Jan '21, but I don’t think my issue is the same.

I have a very poor shot of a bird that I cannot identify (taken in the Margalla Hills just outside Islamabad, Pakistan) Before asking the experts to ID the bird, I tried to extract the maximum detail from the image, and it looks like this in darkroom:

And that is the image I would like to export.

However, in lighttable, or using “w” for full preview, or after exporting with “perceptual intent” or “relative colorimetric”, I get something different - it looks a lot darker:


I’m not sure which tweak in darkroom created the problem - anyone got a clue?

How can I get an export of the image as it looks in darktable?

Zoom preview looks better than the actual image? may apply here as well.

Where do I find the toggle for full data image preview?

It’s mentioned in the thread:

You have softproofing turned on by the look of things?? What if you turn that off and use the toggle mentioned by @kofa

I don’t normally use the softproof option - I only turned it on as the above advice suggested it. It makes no difference.

The zoom preview mentions the toggle, but doesnt say where to find it. I am running 4.8 and searched thru the options but couldnt find it.

Any clues??

look at the link above… provide by Kofa… the screenshot shows the icon to toggle it from the lower screen status bar…

And forget rendering intents the default DT profiles are matrix based and selecting rendering intent won’t make any difference…

Why is your dt version -dirty?

What is your output color profile?
What is your working profile (inside the 'input color profile` module?
What is your display profile (right click on the softproof button)?

Todd - thanks - I knew that icon, but didnt realise it was the preview thingy. Toggling it gives the same image as ordinary darkroom ie not the darkened image.

Version is -dirty likely because I skip the integration.update tests:
git config submodule.src/tests/integration.update none

I do the same and can get builds w/o “dirty” flag…

1 Like

Me too. Dirty means locally modified files, git status should help.

1 Like

Srgb might be okay but a better match for your display profile and I’m not saying the softproofing profile but the display profile would be…

Best to use a calibrated icc file…this is of course not possible for everyone.
Next the manufacturers provided display adapter icc might be better and there may be small gamma difference from just slapping the rgb profile vs the correct icc for your display…

I’m not sure if any of that would impact your issue but it is likely a slightly better setup as I find display adapter icc can be tuned a bit I think to deal with blacks that is not a mirror of sRGB

So to confirm you use the toggle and still you see a mismatch in the DT preview and the LT preview and also a darker export… and you have not changed anything in the preferences … like performance over quality or some other settings…

Maybe its because I dont include EXR in the build??
I just did a rebuild and version is now: 4.9.0+48~gb7c204322e-dirty

Todd that is confirmed. The only thing I can think of that I messed about with recently, is the Print view.

Ah I am on windows so I have never interacted with that part of DT… and as for Linux I am not sure about the nuances of color management there. I see posts and read about it from time to time but I would have to spend more time to try to understand that. Even windows can be a challenge at times even though it shouldn’t be.

Recently I edited a picture on my phone…Pixel 8. When I viewed the preview in file explorer it showed the edit… I had done a sort of bleach bypass look messing around in the phone. WHen I opened it up to see the full image. Windows photo viewer had ignored the edits… I would have thought it was being used by the file manager for preview…

I opened the image in xnview my default viewer and it showed the edit intact…

Windows photo is also doing some autoenhance to images…you open them and for a second or two they look right and then the screen refreshes and they are brighter and maybe less contrasted… I see many complaints about this and apparently there used to be a toggle to turn off auto enhance but that is now gone in Win11 and various tweaks of the registry shared online don’t seem to work either…

So it would seem like it should not be so difficult in 2024 to get color right given what all the fancy AI is supposed to be capable of… this is likely the moment that an Apple user is now having a chuckle…

X11 or Wayland? KDE? What are your system color management settings?

What viewer for the jpg?

What happen when your pressed the full processing new button?

I’m on Mint 21.3, X11, nvidia - 535.183.01 no changes to basic colour mgmt.
jpg viewed with digiKam 8.3 or gwenview, or indeed darktable.
Nothing changes in darkroom when the full processing new button is pressed.

Actually, I solved the problem the old fashioned way - I duplicated the image and started processing from scratch. Hey presto the problem went away - the exported image looks just like the darkroom image.

Something about the first XMP file must be out of line.
I can upload both if you are interested, but I won’t be putting the play_raw tag on them!

Please upload both. I’m not sure if I will have time to look at it.

R6II0197.CR3 (24.9 MB)
R6II0197.CR3.xmp (15.0 KB)