Exporting: high quality resampling and local contrast preset (Diffuse or Sharpen) bug


I have just noticed that with the latest stable build (4.6.1) on an Intel Mac, if I use the “local contrast” preset of the Diffuse or Sharpen module, together with the option “high quality resampling”, I get a totally borked jpg with only stripes (see attached). If I turn off “high quality resampling” the jpg looks fine. This seems to happen with a Ricoh GR DNG files, but it does not happen with a Fuji RAF file.


I am also attaching the DNG file + xmp.

Did anybody else notice this?

thanks for any comments

2022-09-25_R0039801.DNG (11.6 MB)
2022-09-25_R0039801.DNG.xmp (9.7 KB)

Not able to reproduce with 4.7.0+637~g29696745cb, Ubuntu 22.04.
Used exactly your export settings, except style = none.

Thank you, I can try to download the 4.7.0 too and see whether the issue is solved.

…however, I’ll wait a bit to say whether somebody else replicates this with 4.6.1 as I am a bit worrying about messing up my (fairly large) catalog.

Do you see it still as noted if you don’t add the frame style on export??

Yes, without the frame style I get the same striped mess.

1 Like

Hopefully someone on a Mac and 4.6.1 can confirm for you. I’m running a version of the master branch and Windows so I can’t try to replicate your issue… there are a few Mac users so someone should be able to try it

downloaded your attached file and XMP and exported same settings without frame and I get same bar image.

Mac intel 4.7.0+596~g9099467c5d

If you can reproduce it, then we should start a GitHub issue to track this. Can you reproduce with/without opencl? A log from -d common can help in finding root cause.

I can not reproduce on Windows running 4.7 so it sounds like a bug affecting macs.

It worked fine on my M1 macOS 14.3.1 with dt 4.6.1 web install.

Mine is an Intel mac though…

Thank you g-man for the suggestion.

So, disabling opencl the jpg exports fine (but it takes quite a bit of time).

I am attaching the log from -d common, with opencl enabled, in case that may be useful in finding the cause of the issue.

dt_log_with_opencl.txt (18.2 KB)

using dt 4.61on -** Ubuntu ** it opens and exports fine with intel i5-11400H

It looks like a Mac/opencl issue, then.

1 Like

This should go into a GitHub issue. I’m on the cell and some of the ROI in the lens looks suspect, but hard to read in a small cellphone screen.

I found out that the culprit is the Diffuse or Sharpen module, specifically the “local contrast” preset. I’m going to open an issue on GitHub. Thanks for the assistance.