exposure blending with accurate mask

I saw a YT video a few months ago and should have saved it and now I need it. It may have been about using Photoshop but the technique should be generic.

The issue is, I have two photos of the same subject (taken using a tripod) at different exposures because the sky is nice but bright and the foreground is nice but darker. There is a pretty hard line between the two, a line of trees. The video talked about how to shape the line between the two so when the two exposures/layers were blended, there were no halos and the shape of the mask was accurate. Did the video creator use something like a high or low pass filter? I don’t know, I can’t remember.

However, once the mask was created, there were portions that weren’t black so it was painted black, which was fine, the critical part was creating the edge accurately.

Any suggestions?

You probably want luminosity mask, which @patdavid has written about in depth here: https://patdavid.net/2011/10/getting-around-in-gimp-luminosity-masks.html

1 Like

You can also sometimes add just a touch of blur the luminosity mask to help the sharp transitions be just a little bit smoother (adjust to taste of course).

Sorry everyone for this, I didn’t think the solution would be so “obvious” (or previously discussed as much as it has). I thought it might have been done through high or low pass filters so I searched those, I also searched for blending exposures but nothing came close to what I was looking for. It may have been in one of the search results but I just didn’t recognize it.

I haven’t tried luminosity masks before but I understand the principles. I’ll review the comments and suggestions here and give it a try.

Thanks all.


Nothing to apologize for! Sometimes it’s easy to miss options (especially if you’re not sure what a good search term might be - half my time is spent figuring out what to search for before I can find anything useful!). :smiley:

Feel free to post back any time if you make some headway and have any questions! (Or just feel like sharing).

1 Like

I’m using 2.10 and I’m not aware of GMic being ported to this version.

@jrickards @William_Bradley Welcome to the forum!

You can install G’MIC from http://gmic.eu.

I recall there being a video working on a lake+mountains image, covering various topics. The author used an overlay blend brush to refine the edges. What overlay does is make bright areas brighter and dark areas darker and thus you would have the edge in the right place.

Of course, when I tried that, you don’t have an edge that is perfectly middle grey, so you would need to occasionally change the contrast to get the brush to work properly. I don’t do stuff by hand normally, so I won’t be making a video any time soon, but I hope that my description of this process helps give you something to think about.

hi @jrickards,

in this tread i have some tips how to handle the edges. This is one photo, but it can also be used for exposure blending too:

There are also other techniques that can be used and accordingly it would be best if you give us an example and we try to find a solution.

1 Like

Awesome, thanks Boris

I’m running Gimp 2.10 on Linux Mint 19.1. I used the PPA and sudo apt-get … in terminal to get and install G’Mic. It seemed to go fine, I restarted Gimp and G’Mic appears at the bottom of the Filters list but greyed out with a broken chain icon to its left (same with another entry below it called Goat exercise, don’t know what that’s all about).

Any ideas as to what’s broken?

You might be missing some QT5 dependencies, although AFAIK the gmic from the PPA (for ubuntu 18.04 / Mint 19 ) is broken. There is a problem with the old version of QT5 that is used in Bionic/Mint 19.

(Actually it might work but will be old gimp-gmic_2.4.5 )

I believe that the Gimp 2.8 (gmic_gimp_qt) zip for Bionic from www.gmic.eu works ok with Gimp 2.10


Other wise I keep a compiled for Bionic/Mint 19 & Gimp 2.10 here. https://www.gimp-forum.net/Thread-gmic-gimp-qt-and-Ubuntu-18-04

Greyed -out Menu Entries ? You need an image open (even a blank canvas will do)

The little “chain” icons? They are the regular non-gegl plugin icon.

Yes, I didn’t have an image open. Duh! LoL

It happens from time to time :slight_smile: Glad you figured it out.