Failure: After update Fuji X-S10 is detected as GFX100 -> all gphoto related stuff does not work any more

Hi,
I messed around with gphoto2 to use my Fuji X-S10 as a webcam. In the process I have updated the necessary libraries. Unfortunately, this did not work very well → no capturing possible. Even worse, it somehow disabled the abilities of Rapid Photo Downloader such that this device cannot access the data on the camera (but it is correctly detected as a X-S10).
Strangly enough, darktable (although seeing it as a GFX100) can download all files.
Any help is much appreciated.
Daniel

You haven’t provided any details of your operating system, so hopefully the following will work. Probably darktable is compiled with its own version of libgphoto2.

Fortunately recent versions of python-gphoto2 come with a built-in version of libgphoto2, which might work around the problem that was introduced into your system when you attempted to manually update the system version of libgphoto2.

Update python-gphoto2 like this:

python3 -m pip install python-gphoto2

Do not use sudo. I assume on your system this will install the version of the library that comes with the built-in version of libgphoto2.

1 Like

Hi Damon,
thanks for quick response. However, this was not successful:


I am running the lastest ubuntu. The failure before was:
“user_dan@bigMachine:~$ python3 -m pip install python-gphoto2
ERROR: Could not find a version that satisfies the requirement python-gphoto2
ERROR: No matching distribution found for python-gphoto2”
I tried to re-install according to your website which worked but the problem still remains.
rpd-bug-report-20220423-2.tar.gz (605.8 KB)
It is all my fault I assume. If I remember correctly I installed gphoto2 development libraries last night (too late for me I guess). Sorry for keeping you busy with such stuff.
Daniel

The log files indicate a crash when the program is working with libgphoto2, which indicates the workaround was not successful. For now, I think you have two options:

  1. Revert what you did to gphoto2 prior to today, or
  2. start over

obviously option 1 is far the more preferable option.

Hi Damon,
many thanks. I tried all variants. However, I had to do a full re-install of everything to make it work again. It was about time as some other things were not working properly also.