Fine adjust sliders resist one direction

Hi there,
Sometimes, with some sliders, when I right-click to show the popup that allows to fine tune or type in a value, the slider will initially refuse to go in a particular direction. For example if I try to move it right it won’t move until I move the mouse left and then it like unlocks. That happens sometimes, with some sliders - I found no pattern and it is totally inconsistent - I was clicking darktable to describe my case as detailed as possible and when I switched back and forth between the browser and DT they are suddenly fixed.
Is it something with darktable or my input devices are messing with it? It’s been like this for the last few versions, I also tried Ansel, which claims to have cleaned up UI and it’s the same.

Same for me, so I think your devices are fine. But since I’ve never used this feature, I don’t know if or when it used to behave differently.

Are you talking about the whisker…it may be that if you are high enough that there is a dead spot before the whisker takes control… I have never noticed it but I dont use is much as I use my scroll wheel

Kinda, but once the dead spot is there, next time not.

Height doesn’t seem to matter for me.

Is it global or maybe only a certain module or modules??

It’s global and it’s not only one side. The slider only reacts when I once pass the actual value with the cursor. However, I’m also team scroll wheel. :point_up: :handshake:

1 Like

This is intentional and has “always” acted like this; the popup is meant for small adjustments to the current value, so you are able to open it with a right-click without unintentionally immediately making it jump to the current cursor position. As apostel338 said, you have to cross the line through the current value first before it gets picked up and dragged along with further mouse moves.

In master/4.6 you’ll be able to click anywhere to change the value and then continue changing it by dragging until you let go of the mouse button.


Oh, I get it now! I always right-click the slider at the pointer position, it never occurred to me I can click anywhere. In this case that makes perfect sense.
The reason it’s inconsistent for me is my pointer always ends up to be a pixel on the left or right of the slider position. Then if I happen to drag the other direction I cross the current value and the whisker works. If I’m pulling the other way it won’t move.

1 Like

I have noticed this behaviour ever since coming to darktable many years ago but this is the first time I’ve ever had an explanation for it. The interesting thing is that it only seems to be “locked” when moving the cursor to the right of the current value line. Moving it left unlocks it. I assume this is intentional, but it does feel a bit like unintended behaviour. I always thought it was a small bug, but never cared enough to raise the issue.

edit: forget what I wrote! I’ve tried it more and it does seem to be locked from the left or the right until you cross the value line. I guess I just always went to the right first, then back left over the line and thought it was always just this one direction.

1 Like