FITS from ZWO ASI585MC are opened by default without debayering

When I double click on a FITS file from the ZWO camera Siril open it without debayering and show a black and white image but this camera is a color model. I have to click on the Open button and check the debayer checkbox then open the image again and this time it is in color.
Here are the FITS header from a image of this camera:

SIMPLE = T / file does conform to FITS standard
BITPIX = 16 / number of bits per data pixel
NAXIS = 2 / number of data axes
NAXIS1 = 3840 / length of data axis 1
NAXIS2 = 2160 / length of data axis 2
EXTEND = T / FITS dataset may contain extensions
COMMENT FITS (Flexible Image Transport System) format is defined in ‘Astronomy
COMMENT and Astrophysics’, volume 376, page 359; bibcode: 2001A&A…376…359H
BZERO = 32768 / physical = BZERO + BSCALEarray_value
BSCALE = 1 / physical = BZERO + BSCALE
XBINNING= 1 / Binning factor in width
YBINNING= 1 / Binning factor in height
EXPOINUS= 32 / Exposure time in us
GAIN = 0 / The ratio of output / input
OFFSET = 3 / Brightness(offset) of image
STACKCNT= 50 / Stack frames
WB_RED = 50 / White Balance(Red)
WB_BLUE = 50 / White Balance(Blue)
CBLACK = 0 / Initial display black level in ADUs
CWHITE = 65535 / Initial display white level in ADUs
PEDESTAL= 0 / Correction to add for zero-based ADU
SWCREATE= 'ASILive ’ / Name of software that created the image
SWOWNER = 'ZWO ’ / Licensed owner of software
DATE-OBS= ‘2024-05-29T21:12:39.265’ / UTC start date of observation
DATE-STA= ‘2024-05-29T21:12:39.265’ / UTC start date of exposure
DATE-END= ‘2024-05-29T21:12:39.265’ / UTC end date of exposure
BAYERPAT= 'RGGB ’ / Debayer pattern,such as RGGB,BGGR,GRBG,GBRG
COLORTYP= 'RAW16 ’ / Color space, such as RAW8,RAW16,RGB24
INPUTFMT= 'FITS ’ / Format of file from which image was read
INSTRUME= ‘ZWO ASI585MC’ / Camera model
XPIXSZ = 2.9 / Pixel Width in um
YPIXSZ = 2.9 / Pixel Height in um
EXPOSURE= 3.2E-05 / Exposure time in seconds
EXPTIME = 0. / Total Exposure Time (s)
CCD-TEMP= 35.2 / CMOS sensor temperature in C

This the default behavior.
Siril will never debayer an image by default.

Thank you for the answer, I understand the idea in the general case but when opening a file from the desktop with a double clic it is not possible to check the debayer checkbox making this very cumbersome and frustrating. Maybe a configuration option could be added to decide if we want to debayer opened file by this way when there is no possibility to select the checkbox ?

Hello, I think the problem here is that you want to use Siril as a viewer, and that’s not its purpose.

Not only like a viewer there are many use case where I want to open a FITS file from varius directeories not easily accessible from the Siril file dialog, like external drives on MacOS, and do some processing on it, for example process a previously stacked FITS, doing plate solving, etc…

You can do a drag and drop

I didn’t think about drag and drop… I tried it but couldn’t make it work to open a FITS file, If I drag a file over the display area I could see a green + next to the mouse but when I drop the file nothing happend. How should this work ?

If I drag a file into the display area, it works for me.

Are you using MacOS like me ?

This is now fixed.

Thank you, this was quick !
But will it solve my initial issue if I’m not able to set the debayer checkbox ?

It will, dragging an image with the debayer checked will open the image demosaiced.