FITS OSC files and colour processing

Some of the first targets of my newly-acquired QHY294C OSC were galaxies like M66 and M81 and as I shoot from a light polluted location, I didn’t immediately notice that once processed in Siril, they came out black-and-white - I was shooting in bad conditions, didn’t get much time on target, etc. But one night I got over three hours on the colourful Whirlpool Galaxy and was rather surprised not to see a lick of colour, especially in the companion galaxy. I say this because when I would attach my Fujifilm X-T1 and shoot for even 30s it would pick up colour, so there should be no question that hours of imaging ought to be picking up colour.

So I looked through my data sets and discovered I had an early set of just ten usable 3’ images from the Horsehead nebula I had shot very early and hadn’t processed. So I processed it too… and it came out black and white as well.

Here’s how I was doing it: I figured, since the files were already FITS, that they didn’t need to be “converted”… to FITS, as I had been doing with my Fujifilm RAFs. I would point Siril at the directory, then on the Sequence tab press “Search sequences” and a .seq would be generated. If they were Darks or Flats, I would move on to the Stacking tab and stack them. When it got to the Lights, I would go next to the Pre-processing tab, set the dark and flat … and set “Debayer FITS images before saving” as I assumed this was needed to actually get colour. I’d then go on to Pre-process, Register and Stack.

Once it was done, there would indeed be three channels in the channels window and they even looked a bit different. Over on the RGB window the image would initially be green-dominated - so it looks like there’s “colour”. But once I removed the green noise and/or calibrate the colour, it would come out largely as black and white, with some amount of colour noise (but never colour signal).

Like this (10x180"):

(the image itself is pretty poor - it has a splotch top right which I didn’t get a flat to calibrate out, which probably explains why I hadn’t bothered processing it earlier)

This outcome didn’t make much sense as I could see even with the KStars FITS viewer that there was some colour in the Flame Nebula in each individual frame, so it’s not like there wasn’t colour. Initially I thought it might be related to the fact that KStars and Siril have a disagreement over correct image orientation (Siril renders them horizontally flipped compared to KStars), but I set the “Debayer FITS files in up-bottom orientation” in the Preferences to address this (even so, the images still come out flipped).

After a bit of head-scratching, I decided to carry out a test: “convert” my FITS as I would RAFs … to FITS, using the “Keep three channels” and “Debayer” options. Once converted, I proceeded as usual through the various steps.

Here’s what came out, after some basic colour calibrating and stretching (and horizontal flipping):


So what’s going on here? Why do FITS files need to be converted into other FITS files prior to further processing? I had rather hoped I’d be able to skip what seems a needless step by having a dedicated astrocamera.

How do you dot that? You should never apply the “remove green noise” at this stage.
However, when you already have a FITS created by another software it is likely you have to check the button “Debayer in up-bottom orientation” in settings.

Yes, the “Debayer in up-bottom orientation” in settings was checked, as I wrote:

“I set the “Debayer FITS files in up-bottom orientation” in the Preferences to address this (even so, the images still come out flipped).”

Initially I ran it all in the recommended order but on one round I ran it first, the only reason being to see if the green itself was the problem; it wasn’t.

This is what it looks like having done:
-horizontal flip
-background extraction
-photometric calibration
-histogram stretching

… and no green noise removal.

The first image posted in my initial post accords with following along here (je peut lire le français), once having cropped and flipped the image first:

Please, share your pictures if you want.