Focusing while tethering


I’m currently setting up a spot for product photography in an extra room. I’m still learning. I knew that I wanted to connect the camera to the PC in that room and learned that this is called tethering and it works with a usb cable. I’ve ordered a longer one from tethertools and currently I’m testing with a shorter cable. The computer was always just sitting there without much use, it has fedora linux running on it. I googled and found out that darktable for linux can tether.

Darktable runs now and basic tethering works. Though there is one thing I can’t get to work - focusing. Is there any way to focus the shot within darktable/tethering? Currently the only way I can focus is by manually adjusting it on the lens.

Before I go on with darktable I need to know if focusing from within darktable/tethering is possible or not. Is it a limitation of darktable or maybe my camera (D3400, I might upgrade if necessary), or have I just not found the right button for it to work.


the nikon d3400 would support autofocusing . gphoto2 option is called “autofocusdrive”

I dont know if and how darktable exposes it

1 Like

thanks for your answer. I tried but whatever I set in the darktable tether menu, the focus of the camera does not adjust. it does work manually of course but always having to move from computer to camera isn’t a good workflow.

I tried the program entangle. there the autofocus works.

apart from my d3400 supporting it or not, does darktable tether has the option to just click into the live view and set the focus that way? that’s what I’m looking for. if this would work with a different camera model, I would consider upgrading.

I now realize that I should have posted this in the darktable sub category. sorry for that. I hope a moderator can move it there?

1 Like

I had switched to Entangle since the pictures will be edited later on another computer on the network anyway. I just tried Darktable again and now auto focus works there as well. Don´t know what I was missing or doing wrong before. Problem solved - auto focus works tethered in Darktable for me now.

The Darktable interface has quite a lot of room for improvement. For example the button to take the tethered shot looks more like the heading in that settings section. At first it took me a while to actually figure out where to click to take the picture.

1 Like