Foreground select OK in 2.8 but not in 2.9?

Hi all,

I can get Foreground select to work just fine in The Gimp 2.8
– but neither in The Gimp 2.9.7 (Otto Meier gimp-edge) nor
in CarmeloDrRaw’s appimage. Anyone who can point me into
the right direction, please?

Have fun!
Claes in Lund, Sweden

Greetings @Claes, glad you’re back!

I noticed this too! And mentioned it here: Color Masks in Gimp

GIMP needs to be built with another lib in the AppImage.

Do not use the otto-meier ppa. Works but is not updated. Stick with otto-kesselgulasch/gimp-edge ppa

see: http://www.gimpusers.com/forums/gimp-developer/20167-to-all-whom-it-may-concern#message88571

This is in Kubuntu 16.04 Gimp 2.9.7 from otto-kesselgulasch/gimp-edge last update 4 days ago

Try changing the ‘engine’ to Matting Levin

Some screenshots:

Rough selection, paint in foreground: https://i.imgur.com/jEUxMoQ.jpg
Hit enter to confirm: https://i.imgur.com/UwWfDoE.jpg
Hit enter again to produce selection, selection inverted and cut. https://i.imgur.com/pAluwo0.jpg

Thank you.
I am puzzled, though.
I thought that the Kesselgulasch had moved to otto-meier?!?
Ah well, I will test good old Kesselgulasch again.

/Claes

Sorry. Kesselgulasch gave exactly the same effect as otto-meier, i.e. it did not work.
Wonder what I am missing? I can select tools/selection/foreground and then draw with the lasso-look-alike – but when the two ends (start and end of the selection) meet, the area outside of the selection does not become blue.

/Claes

Might help if you can post your image.

The procedure has not changed much from gimp 2.8

Select the foreground select tool - that automatically sets the free select to draw around the subject.

When the selection is closed, that puts you straight into the paint in the foreground area.

Hit enter shows the mask

Hit enter again releases the tool showing the selection.

Did you change the engine? I found the default very strange.

Not a tool I use much (at all) I find the gmic interactive fg select more useful for my requirements.

Thank you! I simply neglected to hit enter & just sat there waiting :flushed: Now it works the way I hoped for.

/Claes

No need to be ashamed, that was recently changed in GIMP. Before you didn’t need to hit enter after closing the lasso line. I think it’s a step in the wrong direction, but I might miss some details that led to the decision.

https://git.gnome.org/browse/gimp/commit/?id=afb9941c809c5a6bc1e23d342c65547be77d1520

2 Likes

i Cant change the engine. It’s grayed out

What operating system? Do you compile GIMP yourself?

I use windows as my operating system. And for the second question and I just hit download on their page for the most recent developer version.