Fresh install (win) does not start (Bail out! Gtk:ERROR, gdk-pixbuf-error-quark)..

Hello guys! o)

I stumbled over ART last week and have serious trouble getting it to run.
I used the installer to install an official build on 2 computers (ART_v1.21_64bit), but ART just won’t start afterwards.

Then I used an archive from a google drive (dev build I guess: ART_master_1.21-24-g072d604c0_W64_generic_240106).
The zipped version only launches when started from my USB thumb drive, when copied to my local drive, it also won’t start.

Where can I look for the cause of the “launch” problem?
Same goes for Raw Therapee, if I install that, it also won’t launch.

Windows is running fine otherwise, Darktable works and ACR works as well.
So in theory, ART or RT should also do fine, right? If not, please let me know! o)

Thank you!

When using art-debug.exe from the local drive, I get this error output, is there something I can do about it?
Is it the reason ART and RT won’t start?

Maybe it’s being blocked by a firewall, antivirus, or some other anti malware stuff? Just guessing, I’m not much familiar with windows unfortunately…

Have you tried the ART_1.21_Win64.exe download on

1 Like

I don’t think so, I have no issues in general with firewall or the anti virus, if things are blocked, you would get some kind of notification (files moved to quarantine e.g.). The anti virus should also moan about ART being launched from my USB drive, for some reason the “portable” version I just extracted onto that USB drives launches just fine, but as said, not when launched from the local drive. I also have no weird blanks or special characters in the path as can be seen in the command line.

This is also true for the version installed with the installer, the path is:

Yep, that’s what I installed on a Win10 laptop and a Win10 desktop, but these will do nothing when clicking “ART.exe”. There is a process for 2-3 seconds, which allocates up to 90mb of memory, then quits.

Is there some logfile or debug mode I can enable?

Thanks! o)

do you have an ART directory in the %LOCALAPPDATA% folder (e.g. C:\Users\user\AppData\Local\ART)? If yes, try to delete it and rerun ART, and see if it starts now. If nothing changes, edit the options file inside that directory, under [General], set Verbose=2. Then run ART.exe from a command prompt like this:

c:\> D:\bin\photo\ART_v1.21_64bit\ART.exe > log.txt

Then attach the log file here, and let’s see if it gives us some clue…

1 Like

It probably shouldn’t make any difference but that’s not the standard install location on Windows. Have you tried running the installer with admin rights and installing to C:\Progran Files\ART ?

1 Like

Did you enable the “Attachment Manager”? Check this URL

Hello again! o)

Unfortunately, deleting “C:\Users\user\AppData\Local\ART” did not make a difference, I tried that before, but no, there is some progress though, the tl;dr; version starts in the middle of this post.

The log file gives basically the same error as my CMD screenshot above, nonetheless attached for further reference and also as text snippet right here, so the next one can find it much easier:
out.txt (207.6 KB)

Bail out! Gtk:ERROR:../gtk/gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error == NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)

Some searching for this error shows, that this error happens mostly on Linux based systems, e.g.:

Since I was able to download the zip and also download / run the installer, this does not apply I guess, thank you nonetheless! o)

I always run in "admin"context, I have UAC on Windows disabled, so my context is always “elevated”. I tried nonetheless what you suggested, but it did not change anything. Just extracting and using the zipped version also should not need any admin rights, but I also made sure to “Run as Admin” here, just to be safe. You have to be precise when troubleshooting, right? o)

@lphilpot Thank you, yes, it shouldn’t make a difference, but…
Playing with the path, seems to have resolved the issue now! (Well, kind of… o):
It seems ART and RT do not like being run from a path containing a “bin” folder.

So this won’t do:
C:\Program Files\bin\ART

This works fine:
C:\Program Files\ART

Don’t ask me why that is! o)

I guess I am one of very few people using Linux style folders on a Windows system, so probably nobody else ever encountered this issue, just a guess of course.
The error message given in the log / output is a follow up error in GTK, it seems (after some reading). The actual issue on Linux seems to be the “loader cache” of GTK not being readable, uptodate or whatever. The Linux solution to this does not seem to apply to Windows, but it is obviously not needed in this case either. The problem seems to be in the path handling somewhere (“bin” folder), but if you run Linux, then there are different solutions to this, maybe check the links.

Thanks @agriggio for giving a hint to the “Verbose” setting in the “options” file. It’s good to know about it, although the log output turned out to be of little help, it surely will be very useful the next time! o)

So, thank you all! o)
Have a nice weekend everyone! o)