Fuji X-H1 and Rapid Photo Downloader

Hi all,

First time poster and looking to move my workflow over to Linux (at the moment Mint 19.1) after many years on Lightroom. I’ve just got my hands on a Fuji X-H1 which of course isn’t supported by any non-subscription version of Lightroom.

I’ve installed the AppImage of version 0.9.17, but can’t see any files. The camera is recognised, but no files are found. When the camera is plugged in with RPL running in the background, it pops up in Nautilus, then gets unmounted, and RPL tries to scan, but fails with

WARNING scan.py 380: Unable to detect any specific folders (like DCIM) on X-H1

The listing in devices in top left shows the XH-1 but the allocated space is against ‘Other’, not ‘Photos’

gphoto2 --list-files shows the list of files on the camera just fine (I’ve upgraded gphoto2 as the version of libgphoto2 predated the X-H1 in the Mint 19/Ubuntu 18.04 repos)

I’ve tried adding “Slot 1” and “store_10000001” (as reported by gphoto2 --list-files) to no avail

I can post the debug logs, but I’m figuring that’d be more appropriate on the bug tracker - I just want to make sure I’m not missing something obvious first!

I’d say much better to pull the SD card out of the camera and import that way… It should be faster as well.

Yeah, I could just use a card reader and may end up doing so. The camera however has 2 slots and I think depending on settings there are some subtleties over how it writes files - I’ve only had it a week and still getting my head around it. RPL is reporting the correct total size of the 2 cards. Plus I don’t like to admit defeat :slight_smile:

What AppImage? I’m not aware of one.

Perhaps your camera breaks the DCIM specification. Did you consult the program documentation? See https://damonlynch.net/rapid/documentation/#devicepreferences

1 Like

Ah, my apologies! I installed several apps the other day, DigiKam being an appimage, then while searching here for a solution to this came across a thread discussing making an AppImage, so confused the two. It is v0.9.17 however, but installed from the Python installer from the Download page

Ahh, this is it. For the benefit of anybody else who might run into this or similar on another camera,the camera has 2 card slots - “SLOT 1” and (I presume as no files have been written to it yet) “SLOT 2”. Adding “SLOT 1” read the photos. I’d actually looked there yesterday and tried adding “Slot 1” - which didn’t work due to case sensitivity. “store_10000001” as shown below also didn’t work

For reference, this is this output of “gphoto2 --list-files”:

Thanks Damon

Looks like a possible bug in the version of libgphoto2 or gphoto2-python you have in your system. Libgphoto2 should be reporting two different storage locations. It doesn’t seem to be. Difficult to know what’s going on when log files are not attached.