Fujifilm GFX100II RAW Image Editing Issues

Environment: Ubuntu 23.10, Wayland, AMDGPU, Radeon Graphics Cards, MacPro 2013, Mesa 24.0.3+git2403140111.90dcd95c0e7~m~mesarc5, Linux Kernel Linux 6.8.1-060801-generic, Fujifilm GFX100II Camera https://en.wikipedia.org/wiki/Fujifilm_GFX100_II , Image 16bit, Uncompressed, RAF, RAW.

Just wondering if anybody else has experienced issues with editing RAF RAW uncompressed image files using a variety of programs. It has been a hit and miss and I got DarkTable to correctly load the files (using OpenCL), but I primarily use RawTherapee for my workflow which does not correctly open the file (and might not support OpenCL).

On the GFX50S the same RAF RAW uncompressed image on the same computer system opens just fine.

To try out the image as an example you can download:


Maybe Related: Issue with opening RAF (Fuji) raw format files in RawTherapee

The following programs fully work:

  1. DarkTable Flatpak
  2. XnViewMP
  3. Geeqie

The following programs partially work:

  1. gThumb (cannot rotate image, image not rotated correctly and distorted when shot in portrait mode)

The following programs only work for some users, but not for me:

  1. RawTherapee (flatpak, ubuntu install, appimage, & as compiled from source with all options ON)

This camera is newer than the last release of RawTherapee, so it make sense that support is there. You might try a nightly build.

1 Like

Good idea I will give that a try downloading the appimage now. Ah no cigar with RawTherapee_dev_release.AppImage yet. Upon opening and processing the image it shows black only.

Well hopefully support is added soon!

If you can share samples at https://raw.pixls.us that’d be helpful.

Yes looking forward to get back to productive editing! Tried to upload an image to pixls.us but it did not work. _DSF0084.RAF has an example you can download.

There are some samples for this camera on RPU already.

1 Like

ImageMagick v7.1.1-28, using libraw, reads _DSF0084.RAF successfully.

magick _DSF0084.RAF -resize 600 -quality 40 x.jpg


1 Like

RawTherapee still uses their dcraw fork for the time being :smiley:

There is no image of 16bit uncompressed, only 14bit, not sure the 16bit version is needed as well? There is a 16bit uncompressed for the GFX100S camera, but not the GFX100II camera.

The image works on dt for me and others. The OP was able to get it to work on dt using opencl. We asked for logfiles using -d common on the cpu path in his GitHub issue to try to understand what’s happening in his system.

FYI: In case you missed it I provided the -d common log files in original post for darktable (I replaced the prior log).

For RawTherapee for some reason it did not work running:

flatpak run com.rawtherapee.RawTherapee -d common
  An advanced, cross-platform program for developing raw photos.

  Website: http://www.rawtherapee.com/
  Documentation: http://rawpedia.rawtherapee.com/
  Forum: https://discuss.pixls.us/c/software/rawtherapee
  Code and bug reports: https://github.com/Beep6581/RawTherapee

  <Chevrons> indicate parameters you can change.

  rawtherapee <folder>           Start File Browser inside folder.
  rawtherapee <file>             Start Image Editor with file.

  -v Print RawTherapee version number and exit
  -R Raise an already running RawTherapee instance (if available)
  -h -? Display this help message

I did enable logging verbose and the output is included in the RawTherapee post, but not very detailed, and doesn’t show obvious issues except the Can’t load DCP profile ‘(cameraICC)’!

magick works for me too, but it appears to replace the camera profile for vibrancy, chrome, saturation, brightness, contrast etc., so the image comes out a little flat and does not match original. I tried all the magick options none worked to replicate the colour profile.

magick ./DSCF0092.RAF -colorspace sRGB -resize 60% -colorspace sRGB xy.jpg
as an example and I tried others have no effect.

Screenshot from 2024-03-19 14-19-40

Camera RAW:
Screenshot from 2024-03-19 14-20-36

ImageMagick ignores camera settings vibrancy, chrome, saturation, brightness, contrast etc.

1 Like

When you say it works, has anybody tried it on Linux with Ubuntu, Confirmed it works on Windows by one user, but when testing it would be good to use somewhat of the same system where the bug was reported on as a baseline.

If you edit your post 4-5 times hours later, no one is likely to notice. There is no notification on post edits.

I was able to open the image and process it. I’m running Fedora 39 KDE with nvidia opencl. I run current master (not 4.6.1). I don’t know if other users run Ubuntu on a 2013 Mac.

Ok thanks, so it’s better to use the post information in reply to get users notified - got it. I think any computer running ubuntu with a radeon card using AMDGPU would be ideal, there is probably not a lot of folks that use the MP.

You described in GutHub that it works for you using OpenCL, so the AMDGPU is not really relevant. You get a black image in the CPU processing path. The image is very large, so processing it will be resource intensive.

I’m not at home for a few days, so I can’t test with only the CPU path.

1 Like

Thank you so much for explanation. I added my CPU information in case it is relevant to the post.