Fujifilm X-T2 support?


(David) #1

I would quite like to try RawTherapee. Any news on when X-T2 files will be supported?
David


(Morgan Hardwood) #2

Keep an eye on https://github.com/Beep6581/RawTherapee/issues/3229


(David) #3

Thanks, I’ve bookmarked the page.
I see RT shows the thumbnails for uncompressed RAF files but crashes in both Windows and LInux when an attempt is made to open them.


(Sebastien Guyader) #4

Hi @DavidS, in fact RT has no problems opening and editing X-t2 / X- Pro2 uncompressed raw files. Only compressed raw files are not yet supported, but support for these should be added in the near future.


(David) #5

Hello Sebastien.
Thank you for your reply. RT edits my XT-1 files fine, but crashes either as soon as the XT-2 thumbnails are shown, or when I try to open one in the edit screen. (Windows 7 64bit). The files are not compressed.
I sent an XT-2 file to a friend who runs Linux and the same thing happened. I assumed that XT-2 support was not ready.
Should I start another thread?
David


(Mica) #6

Hi @DavidS,

What version of RT are you using?


(David) #7

The latest “fast” from the downloads page. 4.2.1234


(Ingo Weyrich) #8

I just tried one uncompressed XT-2 file on current master branch. Works fine here (Win7/64)


(David) #9

SOLVED.
I checked the download and had WinVista_64_4.2.1234.exe
Re-downloaded and got WinVista_Gtk3_Release_4.2.1234 and that works fine.
Thanks


(Olga) #10

You are lucky David. I have the same problem, but I am a Debian user. X-T1 RAFs open, but as soon as I try to open X-T2 RAF’s the software crushes immediately. The RAFs are uncompessed. The RT version is 4.2-1+deb8u1 Any suggestions?


(Mica) #11

@Olga I’d suggest you remove the Debian-supplied version and instead use the Open Build Service repository; it’ll get you the latest version. This is for Debian Jessie.

  1. Open the terminal as root and paste this code into it:
echo 'deb http://download.opensuse.org/repositories/home:/rawtherapee/Debian_8.0/ /' >> /etc/apt/sources.list.d/rawtherapee.list 
apt-get update
apt-get install rawtherapee
  1. You can add the repository key to apt. Keep in mind that the owner of the key may distribute updates, packages and repositories that your system will trust (more information). To add the key, run:
wget -r http://download.opensuse.org/repositories/home:rawtherapee/Debian_8.0/Release.key
apt-key add - < Release.key

RawTherapee should now be installed and ready for use.

I pilfered these instructions from the Rawtherapee downloads page.


(Olga) #12

Have already done that, same results though - would start up but would not open the RAF


(Mica) #13

I grabbed some X-T2 RAF files from here and they open up fine for me. If you’re still having problems, please post a sample file.


(Olga) #14

Extremely strange result! No, RAFs still crash, but NEFs after opening change from normal colour to a weird reddish brown - oh dear!


(Olga) #15

I think the bottom line is that I do need a newer version of RT, and the question is how to install the testing 4.2.1395-1 on stable Jessie without messing the system up… hmmm…


(Mica) #16

@Olga sudo apt remove rawtherapee and then follow the instructions here: Fujifilm X-T2 support?


(Olga) #17

Mica, it is really the same thing you recommended to me above. I did try to install it, it did start up after I installed it and it did crash again as soon as I tried to open X-T2 RAF… Either I am unlucky of the Fuji made changes in the raw files in the new firmware (I have upgraded my camera to 1.10 firmware)


(Mica) #18

If you feel it is a change in the raw file format, please post a raw file sample.


(Olga) #19

Hurraaaah! I found it! https://kbyte.snowpenguin.org/portal/en/rawtherapee-debian/ it is working now!!!


#20

Since yesterday RT also supports the compressed RAW-files of X-T2 and X-Pro2. It’s still a test version, but working fine for me and some others so far. You need to compile RT from the GitHub-branch “xtranscompressed” to get this feature, but I think it shouldn’t be to long till it is merged to the normal GitHub-branch. More info here: https://github.com/Beep6581/RawTherapee/issues/3229#issuecomment-279159017