Geotagging in darktable for Windows


#1

I have a dual-boot desktop PC with Ubuntu 16.04 and Windows 10. I am able to geotag photos using a GPX track file in darktable for Linux. However, when I attempt to do so in darktable for Windows using the same photos, GPX file, and procedure, I have no success. I always receive the message, “applied matched GPX location onto 0 images.”

Has anyone succeeded in using the geotagging module with a GPX file in darktable for Windows?


(Mica) #2

There was an interesting problem here regarding geotagging: darktable for Windows

Can you tell us which version number of darktable and make sure you’re all the way up to date? A new version was published a few days ago.


#3

In Windows 10, at the upper left corner beneath “darktable” is the following:

2.3.0+1049~g909d17612-dirty

I assume that means it is version 2.3.0, build 1049. I think that is the latest version for Windows, right?


#4

That is the latest version, yes. Do you happen to have a sample GPX file to try with? Oh, and what language do you use darktable in? English?


#5

I really appreciate your help with my problem.

Below is one of the GPS files that could not geotag photos in darktable for Windows but was used successfully in darktable for Linux. The upload process at this website would not allow a .gpx file, so I used Notepad++ to convert it to a text (.txt) file for uploading. I hope that works.

.2017-10-28 1424__20171028_1424.txt (283.5 KB)

Yes, I use the English language in darktable.

By the way, thanks to all who helped produce the Windows port of darktable. After using Adobe Lightroom in Windows for several years, darktable will probably become my go-to photo processor in Windows.


(Mica) #6

You’ve helped in getting it working by reporting difficulties and bugs! Thank you!


#7

I’ll have a look at your file tomorrow.

Earlier today I looked into the problem for a bit and found a possibly related bug: Selecting the time zone doesn’t work on Windows, it always uses UTC. So, did you pick anything other than UTC in the GPX import dialog? And do the image locations look like they are off by the time you selected there when using a longer running GPX track? Provided you have one, for some parts of the world that can be up to 12 hours …


#8

I generally sync my camera clock with my PC clock at my home before leaving on a trip. I live in Central Time Zone (American/Chicago), but it was Daylight Savings Time when I set the clock in the camera taking the photos corresponding to the GPS track I sent you. Thus, it was equivalent to Eastern Time Zone (American/New York). When I used the latter time zone and a time offset of 00:00:00 in darktable in Linux, photos were correctly geotagged using that GPX file. In Windows, none were geotagged.

Tomorrow I’ll see if I can ignore the time zone and use a time offset to simulate the time zone.


#9

I’m back with some success I’ve achieved in geotagging in darktable for Windows, thanks to the information in your previous message, houz.

I selected all the photos in a set corresponding to a GPX track. I then opened the “geotagging” module and set the “time offset” to +05:00:00 and clicked on the check mark. This added 5 hours to the displayed “datetime” of each photo. This 5 hours corresponds to the difference in the camera clock setting and UTC. (America/Chicago with Daylight Savings Time as described in my previous message.)

Then I clicked on “apply GPX track file” and, in the dialog box that opened, I selected the “camera time zone” as “UTC”, selected the GPX track file, and clicked “open”. All the photos were correctly geotagged and verified in the map display.

So it appears my problem was due to what you said: “Selecting the time zone doesn’t work on Windows, it always uses UTC.”


#10

Thanks a lot for confirming. The fix is mostly done and will be part of the final release.


(weyland) #11

I’ve a related issue, on windows 10 with darktable 2.4.1, but opposite in fact.
I find the time zone selection has effect, but the offset seems to not to have.
When an image time is out of the track period and I set an offset to match the track period, I have no success whatever the offset, entered manually or calculated by darktable.
It seems that’s the same for darktable 2.4.2.


#12

Did you actually apply that offset to the images, i.e., select them and then click the check mark button in the geotagging module?


(weyland) #13

Hi Houz, :disappointed_relieved:, my bad, I hadn’t noticed it. This button does change the image time. Thank you so much !