Getting excited about Darktable 2.7...

…but I just cannot install it, 2.7 from source that is.

I figured you’re a wonderful bunch here and I’ll ask if anyone knows why I can’t quite get it right

I read about the LUT abilities of 2.7 and thought “How hard could it be to install it?”

Here is what I know thus far…

Fedora 30 Workstation
5.2.13-200.fc30.x86_64
x270 laptop

I had 2.6.2 (?) installed through the repositories that came with Fedora 30 and it worked a treat

I then downloaded:

  1. darktable-2.7.0~git1850.830bd3867-1571.1.src.rpm
  2. darktable-2.7.0~git1850.830bd3867-1571.1.x86_64.rpm
  3. darktable-release-2.7.0.tar.gz

I then used command rpm -ivh for the src rpm

Seems OK but when I try sudo dnf install darktable I get…

[and@localhost Downloads]$ sudo dnf install darktable
Last metadata expiration check: 0:10:47 ago on Wed 25 Sep 2019 19:00:31 AEST.
Dependencies resolved.

  • Problem: cannot install the best candidate for the job*
    • nothing provides libIex-2_3.so.24()(64bit) needed by darktable-2.7.0~git1850.830bd3867-1571.1.x86_64*
    • nothing provides libIlmImf-2_3.so.24()(64bit) needed by darktable-2.7.0~git1850.830bd3867-1571.1.x86_64*
      ====================================================================================================================
  • Package Architecture Version Repository Size*
    ====================================================================================================================
    Installing:
  • darktable x86_64 2.6.2-210.42 graphics_darktable 4.4 M*
    Installing dependencies:
  • flickcurl x86_64 1.26-10.fc30 fedora 149 k*
  • osm-gps-map x86_64 1.1.0-4.fc30 fedora 46 k*
    Skipping packages with broken dependencies:
  • darktable x86_64 2.7.0~git1850.830bd3867-1571.1 graphics_darktable_master 5.1 M*

Transaction Summary
====================================================================================================================
Install 3 Packages
Skip 1 Package

So I try rpm -ivh on the smaller rpm and get…

[and@localhost Downloads]$ sudo rpm -ivh darktable-2.7.0~git1850.830bd3867-1571.1.x86_64.rpm
error: Failed dependencies:

  •    libflickcurl.so.0()(64bit) is needed by darktable-2.7.0~git1850.830bd3867-1571.1.x86_64*
    
  •    libosmgpsmap-1.0.so.1()(64bit) is needed by darktable-2.7.0~git1850.830bd3867-1571.1.x86_64*
    

Pretty lost at this point so I tried the tar.gz from https://github.com/darktable-org/darktable/releases/tag/release-2.7.0

I unzip to home/darktable/darktable-release-2.7.0 and run ./build.sh

Output of above command is all follows:

*[and@localhost darktable-release-2.7.0]$ ./build.sh *
Darktable build script

Building directory: /home/and/darktable-release-2.7.0/build
Installation prefix: /opt/darktable
Build type: RelWithDebInfo
Build generator: Unix Makefiles
Build tasks: 4

CMake Deprecation Warning at CMakeLists.txt:5 (cmake_policy):

  • The OLD behavior for policy CMP0048 will be removed from a future version*

  • of CMake.*

  • The cmake-policies(7) manual explains that the OLD behaviors of all*

  • policies are deprecated and that a policy should be set to OLD only under*

  • specific short-term circumstances. Projects should be ported to the NEW*

  • behavior and not rely on setting a policy to OLD.*

– Building SSE2-optimized codepaths: ON
– Found little endian system. Good.
– Is the target platform supported: 1
– multiarch triplet detected: x86_64-linux-gnu
fatal: No names found, cannot describe anything.
fatal: bad revision ‘HEAD’
– Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=varargs
– Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=varargs - Success
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=varargs
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=varargs - Success
– Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member
– Performing Test C_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member - Success
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wno-error=address-of-packed-member - Success
– Performing Test C_COMPILER_UNDERSTANDS_-Wframe-larger-than=32768
– Performing Test C_COMPILER_UNDERSTANDS_-Wframe-larger-than=32768 - Success
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wframe-larger-than=32768
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wframe-larger-than=32768 - Success
– Performing Test C_COMPILER_UNDERSTANDS_-Wstack-usage=32768
– Performing Test C_COMPILER_UNDERSTANDS_-Wstack-usage=32768 - Success
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wstack-usage=32768
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wstack-usage=32768 - Success
– Performing Test C_COMPILER_UNDERSTANDS_-Wlarger-than=524288
– Performing Test C_COMPILER_UNDERSTANDS_-Wlarger-than=524288 - Success
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wlarger-than=524288
– Performing Test CXX_COMPILER_UNDERSTANDS_-Wlarger-than=524288 - Success
– Looking for external programs
– Found perl
– Found intltool-merge
– Found desktop-file-validate
– Could NOT find LLVM (missing: LLVM_DIR)
– Could NOT find LLVM (missing: LLVM_DIR)
– Could NOT find LLVM (missing: LLVM_DIR)
– Could NOT find LLVM (missing: LLVM_DIR)
– Could NOT find LLVM (missing: LLVM_DIR)
CMake Warning at CMakeLists.txt:375 (message):

  • Could not find LLVM 3.9+*

CMake Warning at CMakeLists.txt:376 (message):

  • Test-compilation of OpenCL programs can not be done.*

– Test-compilation of OpenCL programs is disabled.
– Missing jsonschema, problems in noiseprofiles.json might go unnoticed
– Found xsltproc
– Found xmllint
– All external programs found
– Found msgfmt to convert .po file. Translation enabled
CMake Error at src/external/CMakeLists.txt:11 (message):

  • RawSpeed submodule not found. You probably want to run:*

  • $ git submodule init*

  • and then*

  • $ git submodule update*

– Configuring incomplete, errors occurred!
See also “/home/and/darktable-release-2.7.0/build/CMakeFiles/CMakeOutput.log”.
See also “/home/and/darktable-release-2.7.0/build/CMakeFiles/CMakeError.log”.

I ran git init then git submodule init and then git submodule update and then ./build.sh with the same result :frowning:

I am now well and truly, absolutely lost, out of my depth or just hang out with 2.6.2 (currently uninstalled, don’t ask) until the friendly folks make a 2.7 release.

I plead here with the good people at pixls.us to not ‘do it for me’ but perhaps why it may not be working for me and other avenues I can go down to attempt at getting 2.7 installed.

Thanks in advance

Andy

I’ll try to post here today all the commands I used to compile darktable on Fedora 30. There are a lot of packages to install.

Thanks r3cov3r, I appreciate you helping a novice user. :computer::woozy_face:

@ambient_fridge
Have you tried installing via the OBS package?
https://software.opensuse.org/download.html?project=graphics:darktable:master&package=darktable

I use it on Debian,
I just download the Grab Binary Packages Direct link.
It supports Rawhide.
Haven’t used Fedora for years.
:+1:

Here are the commands I used to build darktable on Fedora:

Installing required packages:

sudo dnf install libjpeg-turbo-devel.x86_64
sudo dnf install libsqlite3x-devel.x86_64
sudo dnf install libpng-devel.x86_64
sudo dnf install pugixml-devel.x86_64
sudo dnf install cairo-devel.x86_64
sudo dnf install lcms2-devel.x86_64
sudo dnf install exiv2-devel.x86_64
sudo dnf install libtiff-devel.x86_64
sudo dnf install libcurl-devel.x86_64 curl.x86_64
sudo dnf install libgphoto2-devel.x86_64
sudo dnf install librsvg2-devel.x86_64
sudo dnf install dbus-glib-devel.x86_64
sudo dnf install fop.noarch
sudo dnf install OpenEXR-devel.x86_64
sudo dnf install libsoup-devel.x86_64
sudo dnf install llvm-devel.x86_64
sudo dnf install clang-devel.x86_64
sudo dnf install intltool.noarch
sudo dnf install gtk3-devel.x86_64
sudo dnf install libwebp-devel.x86_64
sudo dnf install json-glib-devel.x86_64
sudo dnf install saxon
sudo dnf install colord-devel.x86_64 colord-gtk-devel.x86_64
sudo dnf install gnome-doc-utils.noarch
sudo dnf install ImageMagick-devel.x86_64
sudo dnf install flickcurl-devel.x86_64
sudo dnf install openjpeg2-devel.x86_64
sudo dnf install iso-codes-devel.noarch
sudo dnf install libsecret-devel.x86_64
sudo dnf install GraphicsMagick-devel.x86_64
sudo dnf install lua-devel.x86_64
sudo dnf install osm-gps-map-devel.x86_64
sudo dnf install cups-devel.x86_64
sudo dnf install po4a.noarch

sudo dnf install git
sudo dnf install cmake.x86_64 cmake-fedora.noarch
sudo dnf install make
sudo dnf group install “C Development Tools and Libraries”

Getting darktable code from git:

git clone git://github.com/darktable-org/darktable.git
cd $HOME/darktable
git submodule init
git submodule update

Compile:

mkdir $HOME/darktable/build
cd $HOME/darktable/build
cmake -DCMAKE_BUILD_TYPE=Release …
cd $HOME/darktable/build
make
sudo make install

Starting the program

$ darktable

Thanks @ukbanko! I think I tried this roughly a week ago and had some issues, not this time though!

I think I was getting 404’d for the .repo address after I checked in a browser as to why it wasn’t working, hence my “I’ll just build it from source” debacle.

And thanks also to you too @r3cov3r, you’re very detailed list was next on the list to be tried.

@r3cov3r is darktable you use often or is it just to organise photos and some adjustments here and there?
I’m three or four years into using Linux as my only photography workstation and absolutely loving the programs and community.

Cheers

2 Likes

Darktable is my main raw editor. For organising photos I use only directory structure on disk.

dnf builddep darktable

Or just use

http://download.opensuse.org/repositories/graphics:/darktable/Fedora_30/

1 Like

Thanks @asn
The “builddep” command is new to me, learning everyday!