GIMP 2.10.22 exports only TIF?

(Windows 7) Opened up a TIF (scanned doc) in GIMP and tweaked the Curves, then tried to export. It will export a new TIF but no PNG or JPG. Also tried this after launching GIMP with admin rights. Same…

Saving ‘C:\Users\Okie\Desktop\Tax-IRS-2020-1040.png’ failed:
Could not open ‘C:\Users\Okie\Desktop\Tax-IRS-2020-1040.png’ for writing: Permission denied

Did you check Image/Mode -> RGB (not indexed) before exporting? (the usual suspect)
Also, Did you tried File/Export as… (Shift+Ctrl+E)?

The Mode show RGB, but I switched it to grayscale and back to RGB as an experiment. No luck.
That export as method is standard for me.

Maybe this is more about permissions that file types???

Google didn’t tell me much, except this possibly related … https://gitlab.gnome.org/GNOME/gimp/-/issues/1370

At this point, I plan to download the Partha installer again, and start over. Will report back.

Uninstalled 2.10.22,
Downloaded installer from Partha.com, ran As Administrator,
Added GIMP to the “don’t block” list in my anti-virus software,
Found a tutorial on this type of Windows 7 “permissions” error and gave full control by Everyone to the GIMP 2.10.22 folder in Programs,
Launched GIMP and opened the most recent .xcf file,
Tried to export that as a PNG,
Got exact same error message.

Re-installing might do nothing if you kept all your user setting.
Did you try to reset all your setting by default?
I’m not Windows (Linux here), but the path should look alike more or less the same
/home/username/.config/GIMP/2.10/
rename the “2.10” directory by “bak.2.10” or which ever a name you would like as backup
then star GIMP (it will create a new 2.10 directory with default setting and ignore your personal setting in the renamed directory) then try to save your .png from the tif

I followed all these steps; renamed the user settings folder, deleted the previous GIMP install, re-downloaded the new GIMP installer and ran it, rebooted, opened GIMP and opened the most recent image, tried to export a JPG, and got the same error.
Also tried launching GIMP as administrator but same error…
Saving ‘C:\Users\Okie\Documents\tmpKP-pics__iphone\pictoral\dng\converted\CSVB9656-tex-Mex_spot-DA.jpg’ failed:
Could not open ‘C:\Users\Okie\Documents\tmpKP-pics__iphone\pictoral\dng\converted\CSVB9656-tex-Mex_spot-DA.jpg’ for writing: Permission denied
Plus I’ve done more Googling of permissions in Windows but arggg no clues. Why just GIMP and none of the other apps??

Last night, downloaded and installed darktable. I can open TIF files from RT and export JPG.

Not a real solution, but a temporary patch.

I had a similar problem on my Surface 3 tablet, where I couldn’t save images from my rawproc software to folders on a SD card that I’d originally mapped the user’s Windows Pictures directory to. I could happily save anywhere else, that is, to any directory to which I hadn’t previously mapped one of the Windows user directories (Documents, Downloads, Pictures, Videos, etc).

I finally solved the problem by replacing the Surface 3 with a Surface 7 Pro, and not doing such mapping pet-tricks… :crazy_face:

SOLVED. I recently switched from a “Partha” version of GIMP to the official version, and poof I can output JPG and PNG just fine.
What a relief.