GIMP 2.10 Released

That’s what I’m hoping someone can help with. Running 64-bit GIMP on Window 10 Home. GIMP 2.08 was fine.

@andrewheard I have been running GIMP 2.10 (RC1, not final release) and it is fine. Go to EditPreferencesIcon Theme → choose Custom icon size:

PS Choosing a different Icon Theme might help, since each set is slightly different in size.

@afre - thanks. I tried each Icon Theme (no joy) before resorting to Custom Icon Size. And as I say, only Medium worked.

Perhaps @jehan can help here.

I see a few issues reported in this thread. Which one was I supposed to help with? :stuck_out_tongue:
Let’s assume the last one, about icons. :wink:

@andrewheard Where did you install GIMP from? Was it I am asking because I remember a bug on Windows with vector icons. This bug has been (presumably) fixed with the last GTK+2 release. So (1) I do hope we use this release (which fixes actually quite a bunch of issues on Windows, not only this one) for the official binaries and (2) we cannot control what third installers use.

When you say “I tried each Icon theme”, have you even tried the “Legacy” one? Because this is a raster theme, and if you also have the problem with Legacy icons, then this is not the same bug I was thinking about.

1 Like

For the G’Mic issue, they just have to rebuild/repackage it. As far as I understood, the code is still right (as it should, since GIMP 2.8 and 2.10 are compatible), but the package they officially provide for 2.8 won’t work out of the box.

The problem was already there during development:
See Gmic isn't recognized in Gimp 2.9.8 · Issue #113 · dtschump/gmic-community · GitHub
A lot of people still manage to have G’Mic work fine on development GIMP, but they had to rebuild it themselves or use third-party builds.

Now all you have to do is wait for G’Mic to make a new release.

P.S.: this is about G’Mic on Windows. On Linux, the G’Mic currently released officially already works out of the box.

1 Like

As for plug-ins with the flatpak: it is a bit annoying (I have not been very happy about this), but in the whole “sandbox” logics, flatpak overrides any XDG folder per package.
For GIMP in particular, you will find everything under ~/.var/app/org.gimp.GIMP/.

That means GIMP configuration directory in particular will be found in ~/.var/app/org.gimp.GIMP/config/GIMP/2.10/ (under this, you’ll find the usual plug-ins/ and other directories).
Note that if you already had the directory before (say you installed first from .rpm/.deb, then moved to flatpak), the original XDG directory will be used in priority (this is a feature I requested, and flatpak developers accepted to implement it, otherwise people would just lose their configuration when moving from one package system to another). But that is most likely not your case.

1 Like

Thanks @Jehan! I will start with some simple SCM files to see if I can get it going

Thanks @Jehan. I downloaded from Yesterday I tried every combination of icon theme and Guess/ Use/ Custom combo box. The only icons displayed with more than 1x1 pixel size was custom=Medium with any theme. No icons were displayed within the Preferences treeview on left side for any theme. But now, maybe after reboot? behavior has changed. Now Legacy theme behaves correctly in the toolbox, Preferences treeview, and for each custom size. The other themes still don’t display any icons in the Preferences treeview, all themes still only display usable icons for Medium custom size, and another change - Small is still single dot on toolbar, Large is now 3x3 icon, Huge is now 5x5 icon.

Any reason why 2.10x can’t install without un-installing 2.8x? Also, anyway short of temporarily renaming the user folder, to keep 2.10x from shanghaiing said folder instead of creating a new one? At the moment, I’m back to 2.8.22 (backed up my user folder; smart this time. Now GIMP runs 30% faster and I have no explanation other than maybe I might be missing a plugin, but so far I’m not noticing it; lol). Anyway, once I get over my unhappiness, I’ll try to look for a portable version of 2.10x for now, but would far better like an installed version. Oh well. :slight_smile:

How did you install 2.10? I have Mint 18.3 too, but flatpak only appears to install 2.8

Alternatively you can try the appimages from @Carmelo_DrRaw from here Releases · aferrero2707/gimp-appimage · GitHub

1 Like

Gimp 2.10 is now here, in all its 32-bit FP glory. Hooray, and thanks to everyone.

A couple of issues on installation from GIMP - Downloads
to Windows 8.1:

  • I had “ShellExecuteEx failed; code 5. Access is denied,” but this was probably down to my computer.
  • Gimp didn’t ask where to install to, or tell me where it was going.
  • It didn’t offer to add its path to my system path. So I had to trawl through the usual suspect directories to find it.
  • It said it was uninstalling a previous version, but didn’t say which (I had 2.8 and 2.9). It didn’t ask about uninstalling. I would have preferred it not to.
  • My old eyes (with cataracts) struggle with gray text on gray backgrounds. I like white text on black background. I guess I can change this, once I have struggled to find how. Is there a “cataract” theme?
  • No problems with icons.

Anyhow, it works. Thanks again.

If you installed Gimp 2.8.22 flatpak, it should’ve updated to Gimp 2.10 by now.

Am I missing something, 2.10 version won’t start. Just spits this to the console, then exits:

../../../babl/babl/babl-extension.c:354 babl_extension_load_dir_list()
        WARNING: the babl installation seems broken, no extensions found in queried
BABL_PATH (C:\Program Files\Gimp-2.9\lib\babl-0.1) this means no SIMD/instructions/special case fast paths and
only slow reference conversions are available, applications might still
run but software relying on babl for conversions will be slow

Missing fast-path babl conversion detected, Implementing missing babl fast paths
accelerates GEGL, GIMP and other software using babl, warnings are printed on
first occurance of formats used where a conversion has to be synthesized
programmatically by babl based on format description

*WARNING* missing babl fast path(s): "Y' u8" to "Y u16"
*WARNING* missing babl fast path(s): "Y u16" to "Y' u8"
*WARNING* missing babl fast path(s): "R'G'B' double" to "RGB double"
*WARNING* missing babl fast path(s): "RGB double" to "R'G'B' double"
../../../babl/babl/babl-format.c:711 babl_format()
        babl_format("CIE Lab double"): not found
'grep' is not recognized as an internal or external command,
operable program or batch file.

win10 x64, gimp build downloaded from

Looks like its still trying to pull babl from 2.9. Try installing again.

turns out, 2.10 was there all the time. I could start it after uninstalling 2.8

1 Like

Perhaps I missed something in the thread above.

I installed 64bit gimp 2.10.02 so it now starts with
/usr/bin/flatpak run org.gimp.GIMP

That works from a linux/bash command line but rawtherapee will no longer spawn gimp.

I edited the rawtherapee “custom command line” for the external editor as above but still get an error dialog (telling me to provide the right path to my external editor).

geeqie → rawtherapee → gimp is my workflow so I need this. Somehow. Someway. I may have to ditch the flatpak mechanism. This was working fine with a development version I installed a month or so ago.

Any ideas?

RawPedia is very precise in what executables it expects when using the “External editor: GIMP” option, and how it expects a custom command line to be quoted.

You’re starting some exotic type of GIMP which involves running a flatpak executable, passing arguments to it just to run GIMP, and on top of that RT needs to pass arguments to that to open a specific image. Figure that out on the command-line, then use that as “custom command line”.

/usr/bin/flatpak run org.gimp.GIMP runs on the command line but NOT from rawtherapee’s “custom command line,” not even when enclosed in double quotes.