GIMP-2.9 can't find open raw files using PhotoFlow


(Elle Stone) #1

Well, the topic is self-explanatory. I’d give details, but I’m not sure what details might be relevant. This is with default GIMP 2.9 updated to a few days ago, and with PhotoFlow and the PhotoFlow plug-in updated to this morning. The same problem obtained with PhotoFlow and the plug-in from last week.

A couple of months ago everything worked, at least in my “CCE” version of GIMP - at that point I didn’t have PhotoFlow installed in the prefix for default GIMP. But now I can’t use PhotoFlow with default GIMP or with CCE.

When run as a standalone, PhotoFlow works just fine. It just doesn’t work as a plug-in.

This is on Gentoo Linux. The other GIMP 2.9 raw plug-ins work with no problem.


(Carmelo Dr Raw) #2

Hi Elle, as a starting point, the GIMP terminal messages would be enough. Meanwhile I will try to reproduce the problem from my side…


(Elle Stone) #3

Hi @Carmelo_DrRaw - Hopefully it’s OK to attach a zip file, but I’m not sure about pixls.us protocol in such cases (my email and also my ftp access to my website both seem to be down at the moment). Anyway, here’s the terminal output: ph-terminal-output.zip (1.8 KB)


(Carmelo Dr Raw) #4

Hi @Elle - the attached zip file was perfectly readable, thanks!

It is still not 100% clear what is going wrong, however I have fixed a couple of obvious mistakes and introduced some additional terminal messages in the file loading phase, hopefully it will either work or help me to fix the problem.

Could you update your code (only photoflow itself, not the plugin) and send me again the terminal output if it still doesn’t work?

Thanks!!!


(Elle Stone) #5

ph-terminal-output-2.zip (11.2 KB)

Here’s the terminal output - thanks! for taking a look at this.

On a slightly related topic, is there a way to uninstall using cmake, short of deleting all the files by hand? With make, you’d type “make uninstall and make clean”.


(Carmelo Dr Raw) #6

Very strange… couls you please run this exact command in your terminal, describe me what happens and send me the terminal output?

  photoflow --plugin "/hdd/data1/ingest/digikam-ingest/Sony-A7/_DSC0648.ARW" "/home/elle/code-install/gimpdefault/install/config/tmp/gimp-temp-90810.tif" "/home/elle/code-install/gimpdefault/install/config/tmp/gimp-temp-90811.pfi"

Thanks!


(Elle Stone) #7

Well, not much happened, the PhotoFlow UI didn’t appear or anything. But here’s the terminal output: ph-terminal-output-3.zip (10.3 KB)


(Carmelo Dr Raw) #8

Hi @Elle - I see from the log that in your case photoflow is simply crashing… the crash seems to be related with some recent changes I introduced in the GTK UI code, however I cannot reproduce the crashes on my system and therefore I’m shooting a bit in the dark.

Anyway, I have identified one more line in which an uninitialzed pointer could be used, and fixed it. Would you mind to update photoflow once more?

Thanks!


(Elle Stone) #9

Hi @Carmelo_DrRaw - Hmm, well, with the newly pulled and built PhotoFlow code, even standalone PhotoFlow doesn’t work - instead the image opens and then flickers endlessly as it resizes itself between “small” and “almost as small”. I think I’ll try again with gtk2 instead of gtk3, if that’s still possible (given my last Gentoo world update, it might not be possible any more).

Anyway, it turns out I also can’t rebuild the plug-in. Earlier this afternoon I had completely uninstalled everything related to PhotoFlow, including the plug-in, to see if the following gimp_wire_read warning was from GIMP all by itself or from GIMP/PhotoFlow:

(gimp-2.9:9081): LibGimpBase-WARNING **: 11:27:17.667: gimp-2.9: gimp_wire_read(): error
phf_gimp::query() called, exec_path=photoflow
stdout:

The gimp_wire_read warning does disappear if everything related to PhotoFlow is uninstalled and then GIMP is recompiled from scratch. But now the plug-in won’t compile.

Anyway, I sent you a private email with the terminal output from trying to build the plug-in. My email is finally back up again, so it seems silly to keep pasting zip files full of terminal output into this thread.


(Elle Stone) #10

OK, @Carmelo_DrRaw let me know the problem with building the plug-in is that I was using “-DCMAKE_BUILD_TYPE=RelWithDebInfo”, which isn’t supported. Changing it to “=Release” allowed the plug-in to compile. I suspect “=Debug” also works, leastways “=Debug” is what I was previously using, and I don’t know why I changed it to “=RelWithDebInfo”.

The “flickering” seems to have been from an experimental setting in the “options” file. Changing that setting eliminated the “flickering”.

And one of the code changes Carmelo_DrRaw made to PhotoFlow to fix the original problem of GIMP not being able to open files using the plug-in, did fix this problem. So now PhotoFlow works both as stand-alone and as a plug-in. And the “gimp_wire_read” error is gone - yeah!

Carmelo_DrRaw - many thanks!