Gimp bucket fill not hiding text

I have a PDF which needs redacting.
I used to use Inkscape to place a black rectangle over text, however Inkscape saving the edited PDF loses graphic images.
I am trying to use GIMP 2.10.18 to add rectangles over the PDF text, however the black bucket fill leaves the text with white outlines.
Any suggestions please?
Screenshot at 2022-06-23 22-57-12

Gimp opens a PDF as a bitmap, a raster image. Always opens at a default 100 ppi so increase the ppi as required.

A couple of suggestions.
For individual words / lines Use the pencil tool which has hard edges. A click at the start then shift-ctrl draws in straight lines. 5. How to Draw Straight Lines

For blocks of text, make the selection, instead of the bucket fill tool (I suspect one of your settings) just click and drag into the selection from the FG/BG swatch under the tools.


I would try and find out why Inkscape is not importing your images. Gimp makes large file size PDF’s due to the low compression used. It is after all one big image. Inkscape does make a better PDF, There is also Scribus but it is slow setting things up.

You might want to look into Scribus. You can import PDF’s and the add filled rectangles to cover the lines of texts, then export as a PDF.

To go back to the original question, Why does bucket fill leave the text with white outlines ? Most Gimp tools have various modes and options. If the bucket fill has “Fill similar colours” set you get the outline. Use the option "Fill whole selection.

Gimp by default ‘remembers’ the last settings used. Easy for a beginner not to notice the relevant mode.

Just a side note: I seem to remember occasions where it was still possible to select text hidden under an image. So depending on how important the redacted information is, you may want to check for that.

The ideal solution is to remove the information. Read the Adobe documentation to help you think through the process:

PS - @eiger3970 Welcome to the forum!