GIMP Crash when copying 1x128 pixel image (repeatable)

I’m using Manjaro with GIMP 2.10.36 , currently up to date (2023-12-25). I don’t know if this is a GIMP problem or Arch/Manjaro problem.

Could I ask other Pixilians to try the following and state their distro and version?

make an 8bit 1x1280 canvas. (or 1x720, 2x112, 2x96...  3x96 is OK though)
Select All (Ctrl+A)
Copy (Ctrl+C)

…and Gimp crashes, for me at least.

Thank you.
Merry Christmas and a Happy New Year.

I had a problem when copying images from Gimp (early 2.10 releases) but it was independent of image size, and turned out to be a problem with the clipboard manager (klipper for me). I temporarily fixed the problem by disabling the image support in klipper, and the problem eventually got fixed after a KDE upgrade.

(I’ve booted into windows at the moment.)

Thanks, I’m using xfce4-clipboard manager in Openbox.

Ubuntu-MATE 20.04 / GIMP 2.10.36 PPA from Panda Jim,
I created the 8bit 1x1280 > Ctr+A > Ctrl+C > works as intended, no crash.
I even tried without any layer but the canvas only, as you said to make a canvas, same > no crash (does not select as there were no layer, but no crash on Ctrl+A > Ctrl+C).

I would think like @Ofnuts , it might be something with your clipboard manager

I’ve tried the above after closing the clipboard manager, but it’s still the same.

Also four patterns I had created 6 months or so ago with 1x1280, 1x720px dimensions will crash GIMP immediately on launch as the patterns are loaded. If I remove from them from


then GIMP will load as normal (only to crash when copying a canvas or layer with the aforementioned dimensions).

I’ll install a totally fresh Manjaro instance on another partition and check it there.

Thanks for the suggestions.

Still on 2.10.34 but no problem creating a 1*720 pattern (.PAT or .PNG), refreshing the patterns list, restarting Gimp, or using it.