GIMP GMIC Preview/Zoom broken [SOLVED]


Using Kubuntu 23.10 (because sound issues forced me to). Gimp/GMic initially installed via package manager from Ubuntu repos. On first attempted use of GMic from within Gimp, the preview shows a black rectangle and the Zoom is set an absurdly high number (see image below). The zoom dropdown shows the expected options (100%, 200% …) yet selecting them has no effect. The “reset” button has no effect.

What I’ve done:

  • Uninstall and reinstall from 23.10 repos - no change
  • Uninstall/purge both Gimp and GMic from repos; install both from flatpak - no change (currently installed)
  • Delete fully ~/.config/GIMP/2.10/ - no change
  • Delete fully ~/.config/GMIC - reset GMIC preferences (UI layout, etc.) but did not fix preview/zoom issue
  • Attempt to install latest download from GMic for the ubuntu jammy and focal downloads - dependency errors for libraries:
    • libilmbase has no install in the 23.10 repos (only a virtual for -dev package)
    • fails with “depends on libopenexr25 (>= 2.5.7)”, which is baffling since libopenext-3-1-30 is installed and 3-1-30 is > 2.5.7
    • install fails with "depends on libtiff5 (>= 4.0.3), which is baffling since libtiff6 is installed and 6 is > 4.0.3

Thus current install is, via flatpak:

GNU Image Manipulation Program org.gimp.GIMP 2.10.36 stable system
GIMP User Manual org.gimp.GIMP.Manual 2.10 2.10 system
G’MIC org.gimp.GIMP.Plugin.GMic 3.3.1 2-40 system
GimpLensfun org.gimp.GIMP.Plugin.Lensfun 0.2.4 2-40 system

And I’m stuck. I have not expored 2.99.x as yet since it seems to me the issue is GMic and not GIMP. There used to be a standalone QT for GMic one could run, but I don’t see that on GMic’s downloads page.

Any help is appreciated!

Well – damned peculiar behavior. I downloaded and built the gmic-qt and a new gmic-gimp-qt as a check on the flatpak/repo versions. Put the new gimp plugin into my ~/.config/GMIP/2.10/plug-ins folder and the flatpak install refused to “see” it. Uninstalled the flatpak version, reinstalled from the ubuntu 23.10 repos and it is “seen” by gimp.

And my test image that works fine in gmic-qt ALSO works fine in gmic-gimp-qt from within gimp. But, the gimp xcf file that I was working on when the zoom/preview issue surfaced does NOT work fine. It still shows as black rectangles in the gmic-gimp-qt plugin and the zoom level cannot be altered. Oddly, I was able to copy a layer from it to a newly opened original and gmic-gimp-qt previews it as expected. So, there is something about this particular xcf image that is throwing gmic for a loop.

But as I can now do the work I want to do, I will mark this as SOLVED even though that xcf image still produces that preview/zoom error. I’ll also keep it around and if any GMIC folks see this and want to have the image for any research, I’m happy to give it to them (it’s an image of an obituary listing so I don’t think there’d be any issues with using it for testing purposes).

That’s interesting. Would it be possible to send us this file somehow, so we can try to reproduce the problem on our machines, and study what happens ?

PogonyiHeadshot_fromObitNo2.xcf (1017.6 KB)

David - hello! Here are both images, the original png and the xcf I’d created. That xcf has two layers, the first the base image which I modified, then duplicated. I confirmed before submitting this reply that the xcf still produces that black rectangle in the gmic preview (as in the image uploaded in the first post).

1 Like

P.S. the visible image is the png image, the xcf is the link.

Thanks I will check it out!

OK, so I’ve been able to reproduce your issue.

  • I load the .xcf file in GIMP, open the G’MIC-Qt plug-in and see a black vertical stripe in the preview window, just as you shown in your previous post.
  • But now, close the plug-in, and you look closely to the image displayed in GIMP: there is actually a selection in the black region of the image !

Apparently, the current selection is saved in the .xcf file as well.

  • When you open the G’MIC-Qt plug-in, it tries to work on the selection, so that explains the weird preview.
  • Unselect All (CTRL+SHIFT+A) before opening the plug-in fixes the issue :slight_smile:

Whoa!! GMIC works on selections now? Sweet!!

I must have inadvertently pressed the mouse key without knowing it when moving across the image.

And that explains the ginormous zoom level and why it wouldn’t change.

Sorry to waste your time though.