Gimp Headache Ubuntu Studio 18.04

Very Frustrating. Every few months after an Update or something my GIMP refuses to start. (There are broken packages) and I can not update my Ubuntu 18.04 to the later verions. This is a huge headache because I run a Sport Photography Business. Last time this happened I did something to revert the PPA and Gimp started working again without completely reinstalling it. I can not remember what I did, but I am sure my version of ubuntu is screwed up but it would be a major hassle to reinstall a newer version. :frowning:

In the meantime, download its flatpak. See https://www.gimp.org/downloads/.

Depending on your demands you might want to look at the appimage as well.

I had some issues with Debian and GIMP last year. Decided to give the appimage a try and I rather like this solution.

Just in case: Snap vs. Flatpak vs. AppImage

I’ve been using Ubuntu Studio 18.04 as well and have had trouble using PPAs, both Gimp( ppa:otto-kesselgulasch/gimp) and Darktable(ppa:pmjdebruijn/darktable-release). I know that the Darktable ppa is no longer being updated, so I used the package on the website for Ubuntu 18.04. To get Gimp working I used the Appimage without having any issues.

Ok, so I did the Flatpack and now it shows there are three versions of GIMP. One does not work the second in the dropdown list was the flatpack and the Third option seems to be the previously downloaded version which works again. This is all so crazy. Very wonky.

There is a learning curve. All the best.

Thorsten Stettin (“Otto Kesselgulasch”) stopped updating his ppa’s since Gimp 2.10.14, due to personal reasons.

@paulmatth Thanks for the info. It was a while back when I tried to update Gimp using Otto’s ppa. I can’t recall the exact problem I had but I’d been using that ppa for years. I opted to use Appimage instead of Snap or Flatpak, but I can’t remember the details as to why.

Ha, I totally forgot about this page: Community-built software.