Gimp hip hip... pas RT hurrah !


#21

I only tested with GIMP.COM build.
If you want to test:

  • download the dev build from https://keybase.pub/gaaned92/RTW64NightlyBuilds/. Uninstall previous version and install dev.

  • download file-rawtherapee.exe from same location. replace the original one in your GIMP installation

  • launch GIMP and select rawtherapee in preferences.

  • open a raw

  • report

Thanks


(lux) #22

thank you gaaned92
I will try tonight.


(lux) #23

Eurêka, it works very well !

No problem at all,

Thanks a lot gaaned92 !


(MareroQ) #24

Hi André.

Are you planning a new RT version for Vista 32 bit?

The current version RawTherapee_5.5_WinVista_32 does not work on my computer running Windows Vista Home 32 bit SP1- [1]*.
My the last working version on RawTherapee is 5.0-r1-gtk2_WinXP_32.
After a simple diagnosis RT 5.5, I found that the problem is related to three dll libraries:

  • libgmodule-2.0-0.dll - [2]
  • libpangoft2-1.0-0.dll - [3]
  • libharfbuzz-0.dll - [4]

I changed these libraries in RT 5.5 for those for coming from RT 5.0-r1-gtk2_WinXP_32. and now I can run RT 5.5.
It is still there a small problem with the context menu - the message [5] pops up but after it is closed, RT 5.5 starts.

Thank you gaaned92 for your work.

Best wishes and happy New Year:
Marek

ps. [*] number on the screenshot


#25

I fear that building for windows 32 bits will become more and more difficult.

  • Firstly , for a while now, 32 bits rawtherapee is no longer maintained.
  • Secondly, as the MSYS2/mingw32 used to build 32 bits versions is updated, the different dependencies may become incompatible with some windows versions. for instance, DWrite.dll should be provided by Windows32 .

Not being a developper and able to reproduce on my PC as it works ok here, I have minimal possibility to help.
I can suggest you:

  • copy somwher the working dlls, and each time you install a new version, replace the dlls in the installed RT

  • perhaps upgrade win vista to SP2 if it is an option.

Sorry for not very helpful in this situation.

What is the last Rawtherapee version compatible with your system?


(Christopher J Dubea) #26

gaaned92

Tried your suggestions as well. I was not successful.

There is no rawtherapee to select in the import/export section of preferences.

The file-rawtherapee.exe you suggested to download was approximately 8k in size where the original is some 47k. Seems to suggest something is awry.

Thanks.

chris


(MareroQ) #27

Hi André.

Thank You for the very quick answer.

In my Windows Vista 32 bit SP1, there is no DWrite.dll file (but I found the correct one for my system on the internet - DWrite 6.1.7601.21935 https://www.dll-files.com/dwrite.dll.html).
I tried the RT 5.3 version in your compilation and it works fine.

So I will keep the files:

  • libgmodule-2.0-0.dll - 2.54.3 (RT 5.3)
  • libpangoft2-1.0-0.dll - 1.40.11 (RT 5.3)

Unfortunately, it still does not work in my GIMP 2.10.5 32 (probably the last version for Vista 32 bit compiled by Samj) file-rawtherapee.exe plugin (although I tried versions with 2.9 and 2.10.6)
I can only open raw file in RT 5.5 and send it to GIMP.


#28

file-rawtherapee.exe is built as part of GIMP, that I am only able to build for 64bits. Thus I cannot provide a 32 bits version.
Perhaps when correction will be commited to GIMP, somebody could build a 32 bits GIMP. that can launch RT :thinking:


#29

@doobs
The size of downloaded file-rawtherapee should be 427k (original being 47k)
There was a problem while you downloaded the file.


(Christopher J Dubea) #30

LOL!

I right clicked on “file-rawtherapee.exe” in Chrome and did a file save-as. This evidently saved the html as the file. Clicking on file-rawtherapee opened the window for file download…

It works now, thanks.

Is there any way to eliminate this command message at the culmination of the import?

image

Thanks again!

chris


(Ingo Weyrich) #31

That’s fixed in dev


#32

:grinning:


#33

@partha
Now with the modification of file-rawtherapee.c, it is possible with the GIMP.com build to open raw files with Rawtherapee.

I tried with your 2.10.8 build, replacing the original file-rawtherapee.exe with the one I built with Windows/MSYS2.
When starting GIMP, Rawtherapee is registered as a raw processor, but it fails to open a file as it is not even called.
I Don’t know how to test.
Have you an idea of what is happening?


#34

I can’t say what’s happening without looking at the logfile. Can you send it to me?

    You'll find the logfile in your $TEMP folder. The logfile is named runGIMP-2.10.8-std-(long series of numbers).log and your $TEMP folder is usually C:\Users\YourUserName\AppData\Local\Temp.

    Thanks,

    Partha

#35

@partha

Thanks to have a look

  • from the error console
   GIMP Error
Calling error for procedure 'gimp-file-load':
Error opening file C:\Users\Andre\AppData\Roaming\GIMP\2.10\tmp\gimp-temp-98000.tif: No such file or directory

  GIMP Error
Opening 'D:\PHOTOS\test\_DSC4024.NEF' failed:

Raw Nikon plug-In could not open image

#36

The logfile is clean and the
plugin is recognized and registered.

    It seems like the plugin is having difficulty finding the temp

file created during implementation?


#37

@partha
I think the plugin file-rawtherapee.exe is not even called.

In order to have more information, could you explain how to write log messages in your Gimp log file from file-rawtherapee.exe .

@heckflosse @agriggio could you also help me to insert debug/verbose messages inside file-rawtherapee and a way to activate/deactivate them (environment variable?)