Gimp hip hip... pas RT hurrah !


(lux) #1

I have the latest versions of GIMP (2.10.8) and RT (5.5-rc2) and I still can’t run RT from GIMP while Darktable never has any problems…:sweat:
Is it that so difficult to make both work?
It’s not a big problem… it’s just “chiant” ! :-1:


(Elle Stone) #2

Where is the RT executable installed? Is it in the same folder as for the darktable executable?

On what operating system?

When you say “can’t run RT” what do you mean? Do you mean RT doesn’t show up in GIMP Preferences as software for opening raw files? Or do you mean RT is listed in Preferences but doesn’t work even when selected?


(lux) #3

Thanks for your interest

Win-7 64 PRO - 8Go RAM - 1T HD

GIMP, RT, Darktable, are in the same folder : **

**
The path is as you can see on the picture ; same things for GIMP parameters.


(Elle Stone) #4

Hmm, no, my apologies, I wasn’t very clear. I mean the path to the actual RawTherapee and darktable executables, not to the plug-ins.

But it doesn’t look like you have the rawtherapee plug-in installed. This is what Preferences/Image Import & Export looks like on my copy of GIMP-2.10:

Comparing to your screenshot, it looks like on your system GIMP isn’t finding any rawtherapee plug-in.

Where is RawTherapee installed on your system and from where was it downloaded? Is it an appimage? What version of RawTherapee?


(Silvio) #5

Hello everyone,

Maybe a similar problem has already been reported for Windows, in the Rawtherapee bug-tracker, on GitHub:

I am not a developer. Therefore, sorry if I am talking nonsense…


(Elle Stone) #6

That looks relevant in that it links to this:

Except @luxapy is running Win-7, not Win-10.

Or maybe the RT executable folder isn’t in the Windows $PATH, which I have no clue how to list “all folders where Windows assumes executables might be” or how to add a new folder to the list. On Linux it’s easy enough to get the list of folders:

$ echo $PATH
/usr/x86_64-pc-linux-gnu/gcc-bin/7.3.0:/usr/lib/llvm/6/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin

Anyone know the equivalent command for Windows?


(lux) #7

HI,
I have the latest versions of GIMP (2.10.8) and RT (5.5-rc2)

The path of the RT executable is correct in my Windows7
(Look the picture).

path_Win7

Both executables : GIMP and RawTherapee are in the “Program Files” folder

Both are at the last release.

I downloaded RT from the site given in this forum.

I don’t know wether I need any RT plugin ?

It seemed to me that RT was self sufficient for that… ?!


#8

Salut @luxapy,

I most certainly am a bit rusty when it comes to Windows, but

a) what is \Calibre2\?

b) why is there a ; in front of C:\Program Files...?

Cordialement,
Claes en Lund, La Suède


#9

Calibre is an e-book manager, advanced an open source.


#10

As you can see in the thread linked above by @Elle, I failed on W10 to get the RT plugin working.
In the 5.5-RC1 and RC2, RT registers itself in a registry key where the GIMP RT plugin can retrieve the exe location.
here
\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\rawtherapee.exe
and here
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\rawtherapee-cli.exe

depending of your install choice, it can be in HKCU.
So if you use the installer it should be automatic.

With Partha GIMP2.10.8, In the preferences/import&export, rawtherapee plugin seems installed.

But when I try to open a raw file I get an error

gimprt2


(lux) #11

Hello Claes,

The yellow text is only the end of the long path text… just before RT, there are many many other path indications.


#12

path

Doesn’t matter how many there are. Mine has ;; in front of and within the list. Of course, I removed them once I found out.


#13

I just commented on the issue.

A guess: the installers give you the choice of installing for a single user or all users. If you choose one for GIMP and the other for RT, there might be a registry, directory and / or temp mismatch.


(Elle Stone) #14

Based on the GIMP (https://gitlab.gnome.org/GNOME/gimp/issues/2083) and RT (linked to above) bug reports for Windows 10, I’m guessing the same bug affects Windows 7. @luxapy - you might want to add a comment to the GIMP bug report and maybe also to the RT bug report.

Does anyone on this list actually have some version of RT working as a plugin for the latest version of GIMP, on some version of Windows?

FWIW and as a very relevant aside, GIMP very much needs code and debugging contributions (I mean somewhat beyond basic bug reports that something or other doesn’t work) from people who use Windows.


(lux) #15

@Claes :slight_smile:

It is not a command but a tree structure.

In french :
Menu démarrer/configuration/systeme/paramètres système avancés/variables environnement


(lux) #16

In the night, I have tried Partha’s version but it doesn’t work either.
It doesn’t matter, I will wait for the right versions


#17

In order to test why the RT plugin doesn’t work, I tried to buid GIMP 2.10.8 on W10: see //github.com/Beep6581/RawTherapee/issues/5084 (last post).
edit: GIMP and RT plugin are built


#18

the equivalent to $ echo $PATH
is set PATH


(lux) #19

You need to modify the path as the piocture below.


#20

I made some progress. see https://github.com/Beep6581/RawTherapee/issues/5084#issuecomment-449715932

It has still to be reviewed and validated :relieved: