GIMP print dialog/preview not working. It say "Printing from win32 application" ****SOLVED****

I have just got a new laptop with win 11. I installed the latest version of GIMP.
When I press print (file>print) the usual print dialog box doesn’t open.
This is what I have been using for years (win 7 and win 10) -

This is what I am seeing now -

My printer works perfectly with Open Office and printing images from win 11 photo viewer.

I took my laptop back to the store and the tech guy says GIMP must have installed as 32bit and not 64bit.

When I press ‘OK’ the image does print but without the exact measurements of the GIMP image I was working on.

Any ideas?

The “tech guy” is talking nonsense.
This is a W11 issue. There is a registry hack that will revert back to the original dialog box.

OK, thanks. Do you know where I can find the hack?

Link to reg hack
As with any reg hack please follow the instructions with care.

Thanks for the quick reply and warning. :+1:

Fantastic … it worked. I guess I should immediately fire the ‘tech guy’!