git clone Rawtherapee receives time out

I tried to compile Rawtherapee on windows. But at this step
git clone git://
I get this message
fatal: unable to connect to[0:]: errno=Connection timed out.

I used the instructions from Rawpedia.

I don’t think that git:// still works (not RawThreapee specific, btw).

Try the following instead:

git clone

Not sure who’s responsible for that part on RawPedia, but it needs to be updated.

Thank you Jacques - this worked.

It seems that more updates are needed, now I’m stucked at
cmake -G “Ninja” -DLENSFUNDBDIR=~/libiptcdata-1.0.4 -DCMAKE_BUILD_TYPE=“release” -DPROC_TARGET_NUMBER=“2” -DCACHE_NAME_SUFFIX=“5-dev” …

It gives
CMake Warning:
Ignoring extra path from command line:
CMake Error: The source directory “C:/msys64/home/kurts” does not appear to contain MakeLists.txt.
Actual directory is ~/build.

I’m not a C++ specialist , my few knowledges in C# and Free Pascal don’t help me here.

Hi Kurt,

First of all, this has nothing to do with C++ as you’re still stuck at setting up the build system. There are two problems here:

  1. Three dots (...) at the end of the cmake command are wrong. Try two. They denote the parent directory.
  2. ~/build might be wrong or is a consecutive error. Lets assume you use ~/build as your source directory for all kind of programs. Then cd into that directory and clone RT into this. cd into that clone (your current directory is now something like ~/build/rawtherapee. Now, create a directory for building there, i.e. mkdir build, and cd into it. You’re now at ~/build/rawtherapee/build. Run your cmake command here, so that .. points to the source directory of RT.


O, mio stupido!
After cloning I left out “cd RawTherapee”.
But now it stops at
– Checking for module ‘exiv2>=0.24’
– Package ‘exiv2’, required by ‘virtual:world’, not found

Did you install the required package?

Not sure which Linux distro you are using but on Debian it is called: libexiv2-dev. Installing exiv2 on its own isn’t enough, you also need that development package.

I try to compile on Windows, using the instructions from rawpedia.
Are there other packeges need to be installed?
And … how to?
Sorry for asking perhaps stupid questions, I thought the instruction would be complete. But now I’ve started and I want to complete it.

Ah, that makes me helping you problematic, I don’t have any Windows experience at all.

I’m sure that there are people here that do have Windows+RawTherapee compile experience, just wait for one of those people to react to your issues.

Did you carefully followed the instructions from the beginning?
Did you installed MSys2 and all dependencies as it is described?
If you build with msvc, you will have to help yourself.:lying_face:

Edit: I used to maintain this part a few years ago, but there were since this time some evolutions.


If you know bash and pacman, building under W10/MSYS2 is about the same as under Linux.

Exiv2 is used to manage image metadata, so I think it won’t be handled by Msys2.
The compilation on Linux (I use Manjaro) was really easy if you use the automatic way. But the instructions for Windows seem to be a bit outdated (apologies if 'm wrong). I am not a developer myself (just QA with a background of programming) and I hoped after installing MSys2 (as it is described) compiling would be analog to Linux.

Of course it will be (and what does one have to do with the other?), it’s an installable package through pacman (or pacboy) just like most. AFAIK, all RT dependencies are available as packages in MSYS2…

What I meant was, that configuring MSys2 would not install all needed dependencies automatically.
So, the package libexiv2-dev is missing as Jade wrote - and which is right one (there are 6 mentioned in Msys2) and how to install it?

Sure. But most RT dependencies are not installed by default anyway, no?

So, how did you know to install the other ones? Just do the same for the new one ending w/ “-exiv2”…

Your last sentence gave me a hint. What I found out:
For Arch/Manjaro there is a command
“pacman -S cmake ninja exiv2…”
The referring command for Windows doesn’t contain an entry for exiv2. After “pacman -S mingw-w64-x86_64-exiv2” (I hope that was the right one) the compilation worked, with some warnings.
But Rawtherapee could not be started, because all dlls in the install dir where missing. I copied them from the appimage (from Lawrence37) and Rawtherapee started.
I will have a closer look at it tomorrow.

I also compile on windows. At the end of the description in RawPedia Windows - RawPedia ( there is a list of things you need to copy …

Thank you. But in this list libexiv2-27.dll is missing.
This instruction needs an update…


If you run ART from a Mingw64 shell,as indicated in rawpedia, the dependencies will be searched in /MINGW64.

Only if you make a bundled build you will need to copy the dlls, but not only.

Thanks to provide here all corrections you found.
Somebody with access to rawpedia will certainly update it.

I just did it again on my main PC, and the last thing to mention is the list of files to be copied.
Compared to the above mentioned appimage, there is at least a new version of a dll, maybe others new or obsolete (I haven’t compared it, just did the self copy as before), and other files/structure for Adwaita.

And thank you to all who helped!