Git pull github/gmic-community gives me this error [SOLVED]

D:\Programs\G'MIC\gmic-community>git pull
remote: Enumerating objects: 114, done.
remote: Counting objects: 100% (114/114), done.
remote: Compressing objects: 100% (8/8), done.

Receiving objects: 100% (580/580), 2.89 MiB | 7.67 MiB/s, done.
Resolving deltas: 100% (379/379), completed with 10 local objects.
From https://github.com/dtschump/gmic-community
   a7c742b..f04c915  master     -> origin/master
error: invalid path 'tutorial/Cauldron Anyone?.gmd'
error: invalid path 'tutorial/Images Have Edges: Now What?.gmd'
Updating a7c742b..f04c915

What to do about this?

Use a terminal that supports utf-8

I see the problem here. Windows does not support these in file names.

  < (less than)
  > (greater than)
  : (colon - sometimes works, but is actually NTFS Alternate Data Streams)
  " (double quote)
  / (forward slash)
  \ (backslash)
  | (vertical bar or pipe)
  ? (question mark)
  * (asterisk)

It’s a major hassle but it is possible to check out affected repos like that on Windows by using the ‘sparse checkout’ feature to exclude the directory that contains the offending files.

This is an example:

I think this should work, if you already have the repo checked out:

Enable the sparse checkout feature:
git config core.sparsecheckout true

Set this option needed for newer git versions according to https://github.com/git-for-windows/git/issues/2777
git config core.protectNTFS false

Create a file .git\info\sparse_checkout:

/*
!tutorial

This would exclude the entire ‘tutorial’ directory.

Ah, another Windows problem :frowning:

Well, I’ll probably change the filename then, and find another way to put the page title in the documentation. Will do that today.

Should be fixed now.

EDIT: Solved. Now I am able to push into gmic-community.