Gmic destroys GIMP?

So i installed the latest gmic (installer version) version alongside GIMP 2.10.14, under windows 10 pro 64bit. After that i tried to start GIMP but it didn’t start anymore. No splashscreen, no error message, nothing at all. So i uninstalled gmic and tried again. The Problem persistet. Then i uninstalled GIMP completly and reinstalled it again, with no result. GIMP wouldn’t start anymore. I tested older GIMP-versions with the same result.

Here is one Crash-Log i got from GIMP:

gimp-2.10.exe caused an Access Violation at location 000000006B2CCE92 in module libbabl-0.1-0.dll Reading from location 0000000000000018.

AddrPC           Params
000000006B2CCE92 00000000000005CE 000000006B2F4C0C 00000000000000CE  libbabl-0.1-0.dll!write_trc  [W:/msys64-gtk2/home/ender/gimp/babl-0.1.66/babl/babl-icc.c @ 499]
000000006B2CDE7A 0000000000000000 000000006B383EC0 000000006B383390  libbabl-0.1-0.dll!babl_space_to_icc  [W:/msys64-gtk2/home/ender/gimp/babl-0.1.66/babl/babl-icc.c @ 642]
000000006B2CE3CE 000000006B383E50 0000000000000000 0000000000000200  libbabl-0.1-0.dll!babl_space_get_icc  [W:/msys64-gtk2/home/ender/gimp/babl-0.1.66/babl/babl-icc.c @ 702]
000000006B2DAAB6 0000000000000000 0000000000000000 0000000000000000  libbabl-0.1-0.dll!babl_space_from_chromaticities  [W:/msys64-gtk2/home/ender/gimp/babl-0.1.66/babl/babl-space.c @ 426]
000000006B2DAE2A 00000000015E3CE0 0000000000E6FD0C 0000000000E6FDE0  libbabl-0.1-0.dll!babl_space_class_init  [W:/msys64-gtk2/home/ender/gimp/babl-0.1.66/babl/babl-space.c @ 480]
000000006B2C16E9 0000000000E6FDE0 0000000000E6FE38 00000000016CC980  libbabl-0.1-0.dll!babl_init  [W:/msys64-gtk2/home/ender/gimp/babl-0.1.66/babl/babl.c @ 141]
00000000618040C0 0000000001686CD0 0000000000000000 00000000015DEEB0  libgegl-0.4-0.dll!gegl_post_parse_hook  [W:/msys64-gtk2/home/ender/gimp/gegl-0.4.16/gegl/gegl-init.c @ 540]
00000000649FF268 0000000001662478 000000000000001D 0000000000000000  libglib-2.0-0.dll!g_option_context_parse
0000000064A00123 000000000000001D 00000000015E3FA0 00000000016C0860  libglib-2.0-0.dll!g_option_context_parse_strv
0000000000860FFA 0000000000000000 00000000015E3C40 0000000000C23088  gimp-2.10.exe!main  [W:/msys64-gtk2/home/ender/gimp/gimp-2.10.12/app/main.c @ 480]
00000000004013A5 0000000000000000 0000000000000000 0000000000000000  gimp-2.10.exe!__tmainCRTStartup  [E:/mingwbuild/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c @ 339]
00000000004014DB 0000000000000000 0000000000000000 0000000000000000  gimp-2.10.exe!WinMainCRTStartup  [E:/mingwbuild/mingw-w64-crt-git/src/mingw-w64/mingw-w64-crt/crt/crtexe.c @ 195]
00007FFFB0AE7BD4 0000000000000000 0000000000000000 0000000000000000  KERNEL32.DLL!BaseThreadInitThunk
00007FFFB0EACED1 0000000000000000 0000000000000000 0000000000000000  ntdll.dll!RtlUserThreadStart

ntdll.dll   	10.0.18362.418
aswhook.dll 	19.8.4793.0
KERNEL32.DLL	10.0.18362.329
KERNELBASE.dll	10.0.18362.535
msvcrt.dll  	7.0.18362.1
ole32.dll   	10.0.18362.113
combase.dll 	10.0.18362.449
ucrtbase.dll	10.0.18362.387
RPCRT4.dll  	10.0.18362.476
bcryptPrimitives.dll	10.0.18362.295
advapi32.dll	10.0.18362.329
sechost.dll 	10.0.18362.267
GDI32.dll   	10.0.18362.1
win32u.dll  	10.0.18362.535
gdi32full.dll	10.0.18362.535
msvcp_win.dll	10.0.18362.387
USER32.dll  	10.0.18362.535
SHELL32.dll 	10.0.18362.535
cfgmgr32.dll	10.0.18362.387
shcore.dll  	10.0.18362.1	10.0.18362.535
profapi.dll 	10.0.18362.1
powrprof.dll	10.0.18362.1
shlwapi.dll 	10.0.18362.1
kernel.appcore.dll	10.0.18362.1
cryptsp.dll 	10.0.18362.1
dbghelp.dll 	6.3.9600.17298
PSAPI.DLL   	10.0.18362.1
WS2_32.dll  	10.0.18362.387
IMM32.dll   	10.0.18362.387
comdlg32.dll	10.0.18362.418
MSIMG32.dll 	10.0.18362.175
VERSION.dll 	10.0.18362.1
gdiplus.dll 	10.0.18362.535
DNSAPI.dll  	10.0.18362.267
NSI.dll     	10.0.18362.449
IPHLPAPI.DLL	10.0.18362.1
DWrite.dll  	10.0.18362.476
USP10.dll   	10.0.18362.476
COMCTL32.dll	5.82.18362.535
WINSPOOL.DRV	10.0.18362.267
bcrypt.dll  	10.0.18362.267
PROPSYS.dll 	7.0.18362.267
OLEAUT32.dll	10.0.18362.535
uxtheme.dll 	10.0.18362.449
clbcatq.dll 	2001.12.10941.16384
MSCTF.dll   	10.0.18362.535

Windows 10.0.18362
DrMingw 0.8.2

On Windows, G’MIC is installing in the GIMP plug-in folder, inside a sub-folder gmic_gimp_qt.
It does nothing more than copying files in there. If you remove this folder, then it’s just like the installation of the plug-in has never been done.
I can’t see how that would stop GIMP from launching properly.

Anyone else got the same problem maybe ?

You may also need to delete your AppData folders for G’MIC and GIMP:

c:\users[your user name]\AppData\Roaming\gmic
c:\users[your user name]\AppData\Roaming\GIMP

If you can’t see the AppData folder, click “View” on the ribbon at the top of your Windows Explorer window, and check the box next to “Hidden items.”

There is definitely something squirrelly going on with GIMP and Win10. It might be the updated Windows Defender security. I don’t have the OP’s problem; GIMP runs ok until I add too many layers and clicks and brushstrokes (maybe it’s a tile cache problem or maybe it’s the undo memory?) at which point Windows does a hard hang – can’t CTRL-ALT-DEL, not even a BSOD. Gotta do a hard reboot. The worst thing is, I can’t find any useful crash reports. All Windows can tell me is the power went off (which I know because I’m the one who did a hard reset).

I uninstalled, then re-installed Partha’s portable, Partha’s standard install, and the Windows installer. No improvements.

Two days ago I deleted my GIMP and G’MIC AppData and every remnant of GIMP I could find on my PC. Re-installed Partha’s portable in my user Documents folder (because Windows Defender is now very touchy about where programs are allowed to write files). I told Windows Defender to exempt the GIMP application and its folder. I lowered my GIMP tile cache (2 gig down from 3 default) and raised the undo memory (1756 meg up from 756). Now it seems to be working but I need to test it with more layers to make sure I didn’t merely postpone the point of failure.

I don’t know how to file a bug report because I can’t pin down what’s going wrong. But since you asked, the OP is not alone in having problems on Win10 that can’t be solved by re-installing GIMP.

Possibly the answer is to turn off Windows Defender entirely and see what happens. Sorry I can’t provide better info but it’s what I got so far.

@Crazy_Dastard Welcome to the forum!

I installed the official distributions of GIMP and G’MIC last week and have had no problems. The error output doesn’t indicate G’MIC as the culprit. The first line mentions libbabl-0.1-0.dll.

One possible source of problems is if you have a system cleaner such as BleachBit or CCleaner. If your settings are aggressive, a cleaning could break GIMP in multiple ways.

Thanks for the tip. I already tried to delete the folders you mentioned. Sadly i didn’t help. I’m definitly going to try your suggestion about the windows defender. Thanks :slight_smile:

It’s very weird… I never used ccleaner or anything like it after the first install routine. I just installed gmic and then immediately tried to start GIMP. Also GIMP ran perfectly fine minutes before the first gmic installation.

Hmmm seems like the error messages differ. If you want i can provide more, but i also don’t want to spam the thread. I can also get you an event log message from windows, if thats of any help…
Message me if you think more error logs would be helpful.

No worries. You won’t because you started it. :wink:

I downloaded GIMP via the official torrent. Comment field states

GIMP 2.10.14 Installer for Microsoft Windows - 32 and 64 Bit - Update 3 - Fixes issue #4385: GIMP 2.10.14 does not start on W10

Ok I tried to delete every little thing about GIMP and gmic, sadly that wasn’t the solution. Also a deactivation of the windows defender is (because of a update i think) not possible anymore. Probably with some digging in the registry i can deactivate him. Maybe someone can enlighten me here :wink: ?

Oh rats, I was hoping your problem got solved. My problem (GIMP triggers a Windows hard hang) is not the same as yours (GIMP won’t load at all, right?) So my advice might not be useful. Still, here’s what I tried…

In Settings > Updates and Security > Windows Security click on “App & browser control.” Scroll down to “Exploit protection” and click “exploit protection settings.” Select the “Program settings” tab, click “add program to customize” and then “choose exact file path” from the dropdown menu. Find your gimp.exe file to add it, click “edit” and then methodically click all the boxes to “override system settings” and turn off the protections. Honestly, I had no idea what I was doing.

Once that’s done, go to the left-side menu and click “Firewall & network protection” and “allow an app through firewall” and choose gimp.exe again.

Now it’s back to the left-side menu for “Virus & threat protection.” Under “Virus & threat protection settings” click “manage settings.” Scroll down to “Exclusions” and click “add or remove exclusions.” Click “add an exclusion,” choose “folder” from the dropdown, and exclude your GIMP program files folder. Then exclude your GIMP appdata folders (both roaming and local) and also the G’MIC appdata.

There might be still more exclusions buried somewhere in the maze of Windows Security settings. Those are the ones I’ve found.

I have also upgraded my graphics card driver (AMD Radeon) and disabled X-Mouse Button Control (all the crashes happened when I was making rapid mouse clicks and drags). My GIMP has not crashed lately but I am afraid to stress-test it because I’m too busy with the rest of my life to deal properly with this debugging adventure.

GIMP is the only software I use that has a problem on Win 10. LibreOffice, Faststone Image Viewer, Simplenote, VLC media player, Firefox and Thunderbird are stable. If all else fails, I will re-animate my old Win7 desktop and use it offline. And wait for future GIMP Windows builds hoping somebody can figure this out.

If you have Win 10 Pro, maybe try running GIMP in a sandbox? Or set up a virtual machine? At this point I’m just taking shots in the dark.

In my previous post, I hinted that there might be an issue with your installer. The GIMP version number might be the same but there have been bug fixes.