G'mic for Gimp 2.99 on Ubuntu


I am running quite well the App image of Gimp 2.99.17 on my Ubuntu 23.10, I tried to install the lastest dev version of the G’mic plugin but it seems not to work.

I’ve put it in the plug-ins directory but it does not appear on the Gimp Menu.

Is there any version I should try to use it with Gimp 2.99.17?

Thank you,

Sorry I didn’t undestand, does that mean there is no compatible version right now because the function gimp_image_get_active_layer must be changed to gimp_image_list_selected_layers?

To change a function name recursively in a some PHP files I do it like that:

find . -type f -name "*.php" -exec sed -i -- "s/get_frames/get_framesStd/g" {} \;

It will open all the PHP files and change the string “get_frames” by “get_framesStd”. If the arguments are the same for these 2 functions get_frames() and get_framesStd(), it will work fine.

Just a reminder : GIMP 2.99 is an experimental version, where things are evolving quickly, e.g. the plug-in API. G’MIC is an external project to GIMP, so we don’t necessarily wish to follow GIMP’s API evolutions in its development version.
When the stable GIMP 3.0 version is released, we’ll be happy to try and offer a GIMP-compatible version of the G’MIC-Qt plug-in.

In the meantime, we (the G’MIC developers) are willing to take into account any pull-requests proposed by users so that G’MIC-Qt can run under GIMP 2.99, as long as this does not break the compatibility of the code with the API of the current stable version of GIMP.

For the moment, we haven’t received any : Pull requests · c-koi/gmic-qt · GitHub

I understand, but it’s still frustrating to see versions that are compiled for Gimp 2.99 on Windows and not for us on Linux, even though this softwares come from Linux, we’re more blocked than people on Windows!

For Windows, they have this version:

I cannot test it I don’t have any computer on Windows!



The official GMIC-QT sources have been updated for Gimp-2.99 (commit b616829):

These sources allow to have this plug-in under Gimp-2.99.17.
The indications for compilation are given on the site.
It’s good news :o)

Thank you but I can’t get them! it asks me for a login and password:

git clone https://github.com/dtschump/gmic.git
Cloning into 'gmic'...
Username for 'https://github.com': LondonUK371
Password for 'https://LondonUK371@github.com': 
remote: Support for password authentication was removed on August 13, 2021.
remote: Please see https://docs.github.com/en/get-started/getting-started-with-git/about-remote-repositories#cloning-with-https-urls for information on currently recommended modes of authentication.
fatal: Authentication failed for 'https://github.com/dtschump/gmic.git/'

I do have an account but it does not work!

Yet if I ask for a got clone of php-barcode-generator it works without asking for any account / password:

git clone https://github.com/picqer/php-barcode-generator/
Cloning into 'php-barcode-generator'...
remote: Enumerating objects: 986, done.
remote: Counting objects: 100% (985/985), done.
remote: Compressing objects: 100% (359/359), done.
remote: Total 986 (delta 653), reused 846 (delta 594), pack-reused 1
Receiving objects: 100% (986/986), 211.48 KiB | 2.11 MiB/s, done.
Resolving deltas: 100% (653/653), done.

Thanks for any help.

Please follow the instructions detailed here : G'MIC - GREYC's Magic for Image Computing: A Full-Featured Open-Source Framework for Image Processing - Download

(The address used in your clone command is not correct).

These instructions are just perfect, I could compile it on first run!

I have put the compiled file on:

cp gmic_gimp_qt ~/.config/GIMP/2.99/plug-ins/

But Gimp-2.99 does not see it!

It’s an AppImage of Gimp and the preference folder of the plug-ins looks good:

But if I run this Gimp AppImage with the verbose

> ./GIMP_2.99.16.r667.g6681fe7267-1-x86_64.AppImage --verbose

I don’t see any line saying it check the folder ~/.config/GIMP/2.99/plug-ins/:

Parsing '/home/adamy/.config/GIMP/2.99/pluginrc'
Querying plug-in: '/usr/lib/gimp/2.99/plug-ins/test-dialog/test-dialog.py'
Terminating plug-in: '/usr/lib/gimp/2.99/plug-ins/test-dialog/test-dialog.py'
Querying plug-in: '/usr/lib/gimp/2.99/plug-ins/spyro-plus/spyro-plus.py'
Terminating plug-in: '/usr/lib/gimp/2.99/plug-ins/spyro-plus/spyro-plus.py'

Should I try the flatpack version instead of the AppImage for successfully add the G’mic plugin?

I think the Appimage and flatpack versions are a bit special, because they embed their own versions of the libraries, and so the plug-in must be compiled with the exact same versions as well (which are unfortunately not the same as the one installed by default on your system).

I must admit i’ve never tried to compile the G’MIC-Qt for an AppImage/Flatpack version of GIMP. My guess is that it’s kinda hard TBH.