gmic_gimp_gtk no go


#1

Ahgggg…

Tried compiling latest 2.3.0 gmic_gimp-gtk and it failed. I can see from the makefile, that option is removed. But I tried anyway.

No more gtk versions? Is that correct?


#2

Thought GTK wasn’t supported anymore…


#3

Looks like not any more, with version 2.3.0

It is just for my kubuntu 16.04, Gimp 2.10.2 flatpak. The gmic_gimp_qt is no problem except for the flatpak.

This from last compile, 27 May which is a version 2.2.4 Works ok, not a problem.

Such is life - David, can I have my postcard back - only joking.


(David Tschumperlé) #4

Yes, that’s indeed the end of the road for gmic_gimp_gtk (unless someone decides to take it over and maintain it).
For the upcoming G’MIC 2.3.0, we have added a new kind of filter parameter point() that adds movable points over the preview window, which means all filters using this feature would not be compatible with the GTK version (and we are planning to use this feature more and more in the future as it allows a more interactive preview window).
At this point, I just don’t know how to do this in GTK, particularly with the old GimpPreview widget that is not easily customizable, so I gave up.

The GTK version of the plug-in has not evolved for years, and its code has always been a bit glitchy (I cannot say I was really proud of it!).

That basically explains the removal of the plug-in code from the G’MIC repository.


#5

Probably not what you want to hear, but if you install DarkTable (the regular version, not flatpak), then you can choose that in the Gimp Import Preference. Then the latest Gimp 2.10.3 AppImage can import SVG files just fine. Gimp 2.10.3 AppImage comes with G’Mic 2.30 QT already installed.

I got tired of waiting for G’mic to make a QT plugin for Gimp flatpak, so that is what I did…


(Mica) #6

Gimp flatpak plugins are a bit of a pickle right now… It certainly has nothing to do with gmic and everything to do with how flatpak sandboxing works.


#7

@racer-x

It is a lovely version, would be even better if it came as a ‘vanilla’ Gimp with no extra scripts and plugins embedded. I like to add my own and update as necessary, do not see the point of downloading 150MB just to update a 8MB plugin.
As it is, gmic_gimp_qt 2.3.0 compiled yesterday works very well in my home-made appimage.

@paperdigits

I am sure it will get sorted out eventually. Is it not more of a problem with the org.gnome runtime being a little on the basic side or is a dedicated QT runtime required? At the moment can I run a gmic_gimp_gtk 2.2.4 in the flatpak, which will have to last.


(Mica) #8

You’d need the KDE runtime, which does already exist on flathub. I assume you’ve installed the gmic deb. The problem with the sandboxing is that you’d need to account for every plugin the user would want, as one flatpak can’t call another flatpak unless it is declared in the json manifest before the flatpak is built.