G'MIC-Qt 2.0.4 Montage stacks layers on top of each other instead of beautifully ordened

problem
gmic

#1

Hello everybody

I was following a YouTube tutorial https://www.youtube.com/watch?v=iM42vx22gwg about making a montage with G’mic in GIMP. I’m using G’MIC-QT v2.0.4 and GIMP 2.8.22 on Windows 10 x64.
So basically I import all my pictures as new layers, fit canvas to images, start filter g’mic-qt > Arrays & tiles > Montage
I select input layers > ALL
I alter padding and frame a bit, the angle variations, then I pick Output as ‘Multiple layers’ and then when I apply these settings, then I am left with the newly created montage layers, but they’re stacked on top of each other. Only thing I can do really is put them in order manually, but that defies the purpose of the filter.

The single layer montage works perfectly and the preview shows them beautifully arranged, but I would like to play around with the layers a bit, so it would be nice if the multiple layer output would work…

Any ideas what may be going wrong?

Cheers


#2

You are correct, and I tried an old G’mic (linux) 1.7.9, it is the same there.

You stand a chance with a work-around, using another gmic filter ‘extract objects’ since you have padding and angle settings. As a minimum you need some padding.

A montage set-up with six layers. https://i.imgur.com/9q1vobQ.jpg

The extract objects dialogue, select in the padding. https://i.imgur.com/tiiLTXj.jpg

Gives this image with layers. https://i.imgur.com/ws2C8QR.jpg

I hit on the gmic extract objects filter while looking for a replacement for the old divide-scanned-images script, worth a try.


#3

Hey Rich

Thank you for answering so quickly and thank you for your time trying to solve it with that brilliant workaround. I never thought about extracting the objects that way. Since I have padding anyways, it’s not even an issue.
Any idea where I can report this bug that has apparently existed for some time now (and also cross platform)? Or do I just leave it here and hope they pick up on it?

Cheers


(G'MIC staff) #4

I’ve seen your message, and I hope I’ll have some time to put my hands on it this week end.
I can’t promise anything thought :slight_smile:


#5

Hah, thanks, that was quick. No rush, as Rich pointed out: there is a workaround available, so it’s not critical :slight_smile:
Thank you for the follow-up.

Cheers


(G'MIC staff) #6

I got an half-solution to this issue. Not completely satisfactory, but at least this works now with multi-layer output.
Should be working after a filter update.


(G'MIC staff) #7

Finally had the time to fix this.
Will be available in a few minutes, with the latest pre-release version 2.1.0 of G’MIC (available from the website).


#8

Waw, I’m impressed, this is exactly how I wanted it.
I tried your first fix, but it wasn’t pretty just as you mentioned, but with this new 2.1.0 build, it works like a charm. The seperate images cropped to their respective sizes, brilliant.

Just a note: Windows (the x64 qt Gimp version) wouldn’t allow me to install your pre-release because it’s from an unknown publisher. You can just ignore the warning and install it anyways, but I’m just giving you the heads up.

Is there anywhere I can donate to your cause? It will be nowhere near the time you put into this, but I feel like I have to contribute something somehow.

Cheers


(G'MIC staff) #9

Good to know this is working as expected. I’ve just released the final stable version 2.1.0 of G’MIC today, so be sure you got the latest builds (not the 2.1.0_pre). :slight_smile:
Solving your issue was actually not that hard, a 10mn fix, but I just needed to get some free time to look at it, end unfortunately, I’m running out of time these days, and it’s not gonna improve this year :frowning: