G'MIC updating issues thread

This thread is for reporting any update issues, whether for the CLI or plugin. Please state your G’MIC version (and GIMP, etc., version, if applicable).

Current predicament of mine is that every time my PR goes through, the changes don’t show up after an update to the CLI and / or GUI. I generally wait 2 days to check but now I stopped caring and keep a copy of the up-to-date code in my user.gmic. However, that can be confusing because I might assume that it is already accessible to the public when it isn’t.

I’m not sure why is waiting 2 days at the min is a big deal. I get updates after a PR gets accepted in a day. There could be some sort of change logs to be placed so that I don’t have to make a thread on reddit.

I cannot retrieve an update for the code after the PR has been accepted. I then wait for 2 days before I report it. Maybe it is on my end. I usually check CLI and not so much GUI (for you, it might be the opposite), so I don’t know if both are being affected equally.

There is actually a script, running every hour, that is gathering all external contributions, and compile them to build the updateXXX.gmic file (which is then uploaded to the G’MIC website).
So, all newly added filters should be available at least after one hour.

Usually when I ask about it (2 days later), it updates properly shortly after. Maybe you did something on your end, or my system or location is the problem.

Checked again. afre_softlight doesn’t have its 3rd parameter yet, which means the accepted commit from 4 days ago isn’t in my update file at the moment of this comment.

i recently updated to gimp 2.10.14, but now g’mic 2.75 won’t open. i just get the error message of:

Plug-in crashed: “gmic_gimp_qt”

The dying plug-in may have messed up GIMP’s internal state. You may want to save your images and restart GIMP to be on the safe side.

would anyone be able to assist me in getting g’mic 2.75 to work in gimp 2.10.14? i’m using linux (solus budgie 4), and i downloaded both gimp and g’mic from the software centre.

@anj Welcome to the forum!

And this occurs every single time you try to open the G’MIC plugin (this specific GIMP-G’MIC combination)? This happens to me but rarely.

thank you!

yep, every single time for the past 4 days.

Could you give us more info on where and how you downloaded and installed your GIMP and G’MIC plugin? As I am not a plugin dev, I won’t know how to make it work or compatible. What I would say is to go back to using the combination that worked for you, in the meantime. Ping @David_Tschumperle.

i installed them both directly from the software centre. i’ve tried uninstalling and reinstalling both, but for some reason all my gimp settings remain the same like it was never uninstalled.

i’m not too sure how to downgrade to 2.10.12. & i’ve tried getting g’mic 2.74 to no avail.

Sorry, I am not familiar with Solus. Try checking the preferences. There you can also see where G’MIC is located.

the plug-in folders are fine. i even made a whole new folder and added it to the preferences, but that didn’t work either. it looks like i might have to wait for the software centre’s g’mic to be updated to the latest 2.8.0 because nothing is fixing it right now.

What settings? Could you please be more specific? A description or screenshot might help.

I would like to add to this.

I am running Gimp 2.10.12 on ubuntu 19.10 with gmic 2.7 flawlessly.

However I want to upgrade my G’mic to 2.8 and nothing appears to work.

Some of the steps i’ve followed are:

  • reinstalling gimp and gmic via the ppa
  • dowloading the foss QT and saving to the plugins folder.
  • removing all gmic files and reinstalling.
  • Sudo Nautilus and going to lib and adding the qt to there.

Despite all of these nothing works and when loading gmic it’s still 2.7.4

How can I upgrade? Some features such as Film Emulation are missing from 2.7.4 and I want the latest up to date version.

@syteanric1 Welcome to the forum! I suggest you download from https://gmic.eu/download.shtml.

Hmm, actually update281.gmic is generated Dec. 6

Maybe the hourly script to generate updateXXX.gmic could be restarted?

head -15 .config/gmic/update281.gmic

File : update281.gmic

( G’MIC command file )

Description : Update file for G’MIC commands and filters (for current version 2.8.1).

( https://gmic.eu )

License : CeCILL v2.1

( https://cecill.info/licences/Licence_CeCILL_V2.1-en.html )

Generated on : 2019/12/06, 09:44

I waited for Perspective Streak to arrive, but it isn’t there.

EDIT: It’s here. Thanks.

Thanks. I have done that and nothing happens.

I set the preferences in Gimp to look for the plugin and it still doesn’t find 2.8

I’ve even removed all instances of Gimp from my machine, installed from fresh (via PPA in terminal) and it still wont install gmic 2.8

I’ve read somewhere that gmic 2.8.4 isn’t currently compiled for gimp 2.10.12 on ubuntu 19.10. Is this true?

2.7 works like a dream. Gimp finds it and everything seems to work. I did Sudo to nautilus and installed gmic to the .libocation, 2.8 loaded but advised it was a ‘dying plug in’ and the had to be removed.

Is there any way around this?

The PPA maintainer Thorsten Stettin has problems compiling the latest gmic’s There is a ‘prepare’ PPA which shows:

Which means at the moment you are stuck with gmic_gimp_qt 2.7.4

If it is just the gmic_gimp_qt plugin then I would try the zip from the gmic site, troll though the downloads at www.gmic.eu until you get to:

Unzip and put that in your Gimp profile ~/.config/GIMP/2.10/plug-ins It should already be marked executable but check anyway. That should supercede the old plugin. Worth a try.

Personally not keen on the PPA version. the Gimp plugin is a dynamic version, with all the rest of the gmic stuff as dependencies. I tried it for someone recently and it pulled in a monster list of dependencies. The gmic.eu zip is a more regular static version for those (like me) who do not use the gmic command line application.

…and one I compiled for myself a few days ago. Seems to working ok, no disasters so far, but it is for 'buntu 18.04 / Mint 19

1 Like

6 days and counting…