Green preview and editor image...

I previously used a older (linux) version of RT on an ancient PC, with no problems at all and would like to continue with it on my new Windows10 PC. However, I am having a problem with processing in v5.8. Initially, the thumbnails appear as normal, but when opened in the editor, the image immediately turns mainly green and black - in both the editor and it’s corresponding thumbnail. This appears to be very similar to the “no demosaicing” example on the relevant help page. I am unable to revert the image back unless I “Clear” the processing, which isn’t much use. However, I am able to “Inspect” the image in RT without the black&green cast. I have been searching through the previous topics and found a similar issue from Mar '16 (“Preview image all green and black?”) - but none of the suggestions in this post have worked for me - i.e. the demosacing is set to Amaze; the “Fill” button has no effect; Dark Frame is set to Auto and White Balance is active. The program seems to be recognizing my camera (Canon 5DII) and lenses correctly as they appear in the appropriate selection drop downs. Using the (very basic) Canon software which came with the camera, the processing to a jpg works perfectly. I also tried some images which I had previously successfully processed (on the old version) - these also immediately turned black&green! Clearly I am missing something here - could anyone suggest anything else I might try please?

Is this enabled?

1 Like

Firstly, thanks for looking at this and apologies for the delay in responding - I have only just got back…

I checked the White Balance tool and it is already in the same state (almost) as shown in your picture - the difference being that I don’t seem to have a “Auto iterate temperature correlation”, mine is just plain “Auto”, so the slider settings are slightly different. Turning the WB tool on and off does affect the image, as does changing the colour temperature - but the overall green&black cast is still largely unaffected.
In an attempt to fix this, before asking this question, I reinstalled v5.8 and then opened a CR2 straight away - without touching any of the controls whatsoever, to make sure that I hadn’t inadvertently changed something to cause it. However, the green&black cast was still present…

Please show a screenshot

The stone lion is white stone, the sky is blue and trees “autumnal”…

I have the same issue… This happens when opening raws edited with 5.6 in 5.8.

This is the file browser in 5.8:

In my case, the problem is that white balance is disabled:

Once I enable it, all is well:


@heckflosse Ingo, do you want me to file an issue?

@bobg Can you provide a raw file to test?

No, 5.6 did not have the enable/disable button for white balance, it was always enabled.
I will see whether I can add a check for old files…

I’ve looked at some old PP3 files; they have these lines:


[White Balance]

I wonder if the Enable line is something you could look for in 5.8.

This is the one in the screenshot.
Note that I have previously processed this exact same CR2 in the old version of RT, without any problems at all. Unfortunately, I don’t remember the version no. of RT that I was using - and that old PC has been scrapped, so I can no longer check.

I already tried the WB on/off button - it doesn’t seem to help me.2012_10_27_0014.CR2 (13.6 MB)

Hm, I wonder if we have different issues, then… they sounded very similar.

I just “processed” this image - this is the WB part of the pp3 file…


[White Balance]

@bobg This was a bug in 5.8 concerning Canon mraw/sraw pseudo-raw files. It’s already fixed in dev. Just use a nightly build and it will work

1 Like

I will try to reproduce your issue now…

How do I do that? - I’m just using the Windows10 install file - Should I download the latest version and reinstall…?

Get RawTherapee_dev_5.8-281-gaa389dbca_20200229.exe from here or maybe better wait until tomorrow and get the new one, as there were some performance issues in latest which will be fixed in new one…

OK, I can wait until tomorrow and then get the new version…
Thanks very much for all your help on this.

1 Like

Was this using 5.8 release or 5.8 dev build?

It was the file RawTherapee_5.8.exe
From the download page.

I asked @mbs :wink: