HDRMerge AppImage - first experiment


(Morgan Hardwood) #21

Great to see this!

@Carmelo_DrRaw if @heckflosse agrees, I think it would be best if you used libraw from GitHub. Reason being is that the latest stable is old (as is the case with RawTherapee), while the latest release - 0.18-Beta3 - is much newer, but probably unavailable in most distros.


(Ingo Weyrich) #22

@Morgan_Hardwood I agree if you tested it. I didn’t :wink:


(Carmelo Dr Raw) #23

That was also my initial idea, but then I ran into some issues with the LibRaw build system from git: it only provides a configure.ac file, and running autoconf was giving me some fatal errors.

Before spending time to investigate the issue, I wanted to set-up the appimage to work with a custom LibRaw version, so I picked 0.17.2.

Now I will come back to the git version and try to solve the building issue…


(Ingo Weyrich) #24

Great, thank you. I’ll not be able to test the new appimage before saturay evening or sunday btw…


(Carmelo Dr Raw) #25

@heckflosse @Morgan_Hardwood New appimage version, this time with LibRaw from git: https://framadrop.org/r/UC-K6kzuRX#yuDB4eYjZZZCmEVcfJfV/I1hJyPhy+kWJ4FYUXa7JIU=

Building from git was actually almost trivial…


(Ingo Weyrich) #26

It works fine but it seems you didn’t use latest hdrmerge master to build it. At least it doesn’t show the libraw version when running with -vv


(Carmelo Dr Raw) #27

Yu are right, I was still using a checkout from few days ago… Now I have uploaded a version from the latest git sources, which we can probably put on the “Community Software” page. Could you maybe write a little intro to describe the package?


(Morgan Hardwood) #28

We want to release a new HDRMerge version once this AppImage has been tested.


(Ingo Weyrich) #29

Tested on Mint 17.2 and Sabayon. Works fine on both :slight_smile:


(Carmelo Dr Raw) #30

Mint 17 is basically the system on which I build the appimage, so it is probably not very representative…

yesterday I had it a go with a Live “Debian Dog” distribution, which has an extremely basic environment, and it was working as well (my GIMP appimage still fails on that system, for example).

Maybe @Morgan_Hardwood can give it a quick try on Gentoo?

EDIT: sorry, I did not realise that Sabayon was based on Gentoo!


(Morgan Hardwood) #31

@Carmelo_DrRaw runs fine in Gentoo, but the Qt theme/engine seems to be missing:

When I run my own build it looks like this:

The console output of the AppImage shows relative paths could be the cause:
https://bpaste.net/show/07a0b5eec820

It asks me every time I run it whether I want to install a shortcut.

The console output also shows you’re using glibc-2.14, is that correct? It’s probably not a problem, but it is 5 years old.


(Carmelo Dr Raw) #32

I will look into the the problem.

Concerning the libc version, the idea is to build the appimage on a relatively old system so that it can run on other old systems…


(Morgan Hardwood) #33

Oh, I thought AppImage handled that… so if you compiled using a newer version of glibc than I have on my system, it wouldn’t run?


(Carmelo Dr Raw) #34

Exactly. Libc itself is not bundled in the appimage, otherwise you get all kind of strange errors.

This is also the recommendation of the AppImageKit developer.


(Carmelo Dr Raw) #35

@Morgan_Hardwood @heckflosse
I have just finished setting-up an automatic AppImage creation for PhotoFlow, using Travis CI. The re-building is triggered each time there is a new commit pushed to GitHub.

Would you be interested into a similar functionality for HDRMerge? In this case, I can try to adapt what I did… should not be very difficult.


(Morgan Hardwood) #36

I think it’s a question for users. I can compile myself whenever I want to :slight_smile:
I imagine it’s something users would love to have.