HDRMerge batch mode help

I need help!
I want to use the HDRMERGE program in batch mode.
With the command hdrmerge --help you get instructions:hdrmerge help.txt (1.9 KB)

What type of command do I write when I want HDRMERGE to automatically combine a series of images. For example, the folder contains the following pictures
/home/yteaot/Kuvat/merge/IMG_3825.CR2
/home/yteaot/Kuvat/merge/IMG_3826.CR2
/home/yteaot/Kuvat/merge/IMG_3827.CR2
/home/yteaot/Kuvat/merge/IMG_3839.CR2
/home/yteaot/Kuvat/merge/IMG_3840.CR2
/home/yteaot/Kuvat/merge/IMG_3841.CR2
the first three and the last three of these fall into one.

It seems like hdrmerge --batch *.arw is the most minimal incantation that will give you output. But there are other switches that may help, like the gap of seconds and so forth.

See https://github.com/jcelaya/hdrmerge/issues/104 for a question about batch mode

After trying out the different options, I found that a good result can be obtained with the command:

hdrmerge --batch -a --no-crop * .CR2

Thank you for your attention!

1 Like

Did anyone ever get this to work? I have tried everything to get batch mode working by specifying wildcards such as *.CR2 and the program will not find any of my files (which are in the same directory as the executable). If I supply the exact file names, such as g26i5421.cr2 g265i5422.cr2 g26i5423.cr2 then it works fine.

Here is a sample commandline I have used that works:

hdrmerge -v --batch g26i5421.cr2 g265i5422.cr2 g26i5423.cr2

Here is what doesn’t work:

hdrmerge -v --batch *.cr2

I’ve tried other variants with other switches but always get the same things whenever I use the * wildcard.

Any help would be appreciated.

hdrmerge --batch -a --no-crop * .CR2 worked for @yteaot in the post above. Have you tried that?

Works fine here in Linux, self-compiled.

hdrmerge --batch *.dng

As my magical crystal ball is busy charging, @Jeff_Goldenberg which version of HDRMerge are you using, which operating system, and what does ls -lah output?

1 Like

Hi - any news on this one? I have the same problem - I’m on windows. I navigate to my photo directory in the cmd line

“C:\programfiles\hdrimerge\hdrmerge.exe” -v -B -a DSC_1860.nef DSC_1861.nef works great but

“C:\programfiles\hdrimerge\hdrmerge.exe” -v -B -a *nef does not.

Any ideas??

I’m using HDRMerge 0.5

Try it in powershell, it has more Unix like file globbing.

@foxmitten2 Welcome to the forum!

Have you tried escaping certain characters using backslash \ or caret ^, or double quoting the entire command?

Maybe *nef is missing a .; i.e. *.nef. Sometimes it makes a difference.

I have not! I’ll try those suggestions - thank you!!