hdrmerge now uses qt5


(Ingo Weyrich) #1

@Morgan_Hardwood and @Hombre moved HDRMerge from qt4 to qt5 \o/

That means, windows msys2 (where qt4 and qt5 can’t coexist) builders should now be able to build HDRMerge and Luminance HDR for windows.


#2

Thanks @Morgan_Hardwood @Hombre. Can’t wait for people to build an updated HDRMerge.


#3

Thanks @Morgan_Hardwood @Hombre

HDRmerge.zip for Windows64
is uploaded at
https://keybase.pub/gaaned92/LHDR64/

Warning: I only tested that it started on my W10 system


#4

@gaaned92 Thanks! I will give it a try :sunny:.

Update

hdrmerge-nogui
This application failed to start because it could not find or load the Qt platform plugin "windows"
in "".

Reinstalling the application may fix this problem.

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

Same result with the GUI.

image


(Morgan Hardwood) #6

@gaaned92 I get the same error as @afre when I run it through wine.


#7

As I have MSYS2 installed, the plugins can be accessed on my PC.
I am searching where those missing files are located in MINGW64.

edit : the files are certainly located in MSYS64/MINGW64/share/QT5 (it is a guess)
Now I am searching where I copy that in the build.

If somebody can enlight me, he is welcome :grinning:

edit : the culprit is the Qt Platform Abstraction (QPA). I have to copy the
MSYS64/MINGW64/share/QT5/platform in the build

edit:
new HDRmerge.zip for Windows64
is uploaded at
https://keybase.pub/gaaned92/LHDR64/

Note: with all this QT stuff, HDRmerge becomes much bigger than RT :open_mouth:


#8

It works!


#9

Expanded on Mac, HDRMerge/Qt5.10 is 32MB, RT is 119.2MB


#10

Spoke too soon. First run of hdrmerge-nogui: no output file (using files from “[Play Raw] First foss processing - panorama”). Second run:

[  0%] Loading CRW_3486.DNG
Number of frames : 1
LibRaw::unpack() failed.
Load files: 0.00445621 seconds
Error loading CRW_3486.DNG, file not found.

Same result with the GUI. image

PS I wonder whether it damaged the DNGs in some way…

image

PPS It is probably my fault. I used --single because it would skip the files otherwise. Anyway, I haven’t used hdrmerge for years :blush:.


(darix) #11
  1. in cmake you need to check for Qt5 Concurrent.
  2. it seems the check for the xdg-utils binaries fails for me so the desktop file and icon aren’t installed. cmake -L reports that both binaries are found.

#12

@gaaned92 What happened to the build? I cannot find it here anymore. :cry: