Help me get rid of graphical glitches/artefacts or downgrade my NVIDIA driver to the previous point release.

I’ve also posted this on my distro’s subreddit and unofficial forums (Pop!_OS / Ubuntu-based), but I’m hoping maybe I can get faster help here.

Every since my distro updated to NVIDIA 440.100 I’m having this sort of glitches when using the Hybrid Grapchics mode on my Optimus laptop, a mode that worked flawlessly up untill the latest NVIDIA driver version.

Now I could switch to NVIDIA Graphics and use it like this, but the one of the main reasons I chose Pop!_OS is the beautiful way it handles switchable graphics on my Optimus Laptop. I would just set it to Hybrid Graphics and forget about it, the OS seemed to always know when to launch heavier apps (like DaVinci Resolve, Blender or Steam games) using the dedicated NVIDIA GPU. To make matters worse, running the OS on NVIDIA graphics, doing pretty much nothing but composing this here post, my NVIDIA GPU is running at a whopping 65°C, and back on 440.82 it used to sit confortably at around 40°C.

How do I downgrade to 440.82? Or maybe there is another way to get rid of these glitches and still use Hybrid Graphics?

My system is fully updated, with vulkan-utils, and CUDA at their respective latest versions, but I wasn’t able to fix this issue.

Thank you.

440.100 or so was a security release IIRC. you dont want to downgrade.

Security update or not, my PC is running very hot (almost 70C doing anything at all) while the previous point release (440.82) worked flawlessly for months. Not to mention the newly introduced graphical glitches.

Say I DO want to downgrade, care to tell me how I can do that?

sudo apt-get install «pkg»=«version» will do the trick.

The package doesn’t specify a point release. Say I were to sudo apt install nvidia-driver-440 it would just install the latest version, .100 in this case, while I would like to install the .82 version.


apt-cache madison apache2

do something like you want? (replace apache2 with your package name, obviously). It should get you the version number to use in @paperdigits command?

Well yes and no. I only see the current release, and some weird previous one, but not the one I had installed.

In the file /lib/modprobe.d/nvidia-graphics-drivers.conf , you will find this line:

options nvidia-drm modeset

Is the value 1 or 0?

blacklist nouveau
blacklist lbm-nouveau
alias nouveau off
alias lbm-nouveau off

options nvidia-drm modeset=1

What does it mean that it’s 1?

Can youbchange the 1 to a 0 and reboot to see if that fixes it?

It doesn’t fix it.

Not sure what to tell you. A package should be versioned. Note that the 440 likely isn’t the full name of the deb file. You’ll need to track down the deb and install it.

Oh well, I don’t seem to be able to do that. I think it may well be above my level as a novice Linux user.

I’ve just about gotten used to the idea that I’m going to run my laptop on the full-on NVIDIA Graphics mode and wait for the next update (445.something) which should hopefully fix it.

Many thanks for trying to help.

1 Like