Help me understand erratic flash behaviour and inconsistent exposure.

I’ve had this happen for the last couple of years but it only now got to a point when it started to be aggravating.

I shoot mostly macro with a Sony a6000, 57mm extension tubes, Pentax M Macro 50mm f/4 and a Godox T685 flash with an off-the-shelf softbox diffuser, slightly bent and modified to fit my needs.

Onto problem number one. I’ve gotten accustomed to shoot with the flash in manual mode, at around 1/16 to 1/8, at around 1/160s, AUTO-ISO 100-1600 and f/8 on the lens. Any shutter speed slower than that and I risk getting trails. Now this is sort of OK, and although I do get images a bit darker than I’d like, it’s nothing terrible and I blame my less-than-ideal diffuser.

All fine and dandy but this is where my main issue begins. A lot of times, and I mean A LOT of times the flash will switch to TTL by itself, sometimes after every shot, so that means I always have to check if my flash is still in M mode before and after every shot. It does this before my eyes. I will set it to M and wathc it change to TTL by itself, the very next second. Set it to M again and it will change to TTL again, by itself.

(Maybe related, maybe not, but it might be worth mentioning that my camera does something similar at times. I usually shoot in S or A mode and it will change through modes by itself. It will go to Intelligent Auto for a second, then back to S, then back to Intelligent auto. Or when I preview an image, or use the zoom to focus assist function it will jump back to the main screen, and I have to fight it, to keep image preview open, or the focus assist zoom window)

Now back to my flash issue, I say why not shoot in TTL mode to avoi all this nonsense. Well, shooting with the flash in TTL mode, even compensated by two full stops, I always get waaaaay over-exposed images, like 5 stops overexposed. They’re so bad, the highlights are burned beyond any sort of recovery. Even with faster speed, even at f/11, TTL almost guarantees an over-exposed image.

Please excuse a rather long post, but I tried to explain my issues the best I could.

For what it’s worth, this is the setup.

Is your flash mounted in your camera’s hot shoe, are you using a wireless trigger, or some other configuration?

It’s mounted on the hot shoe.

Good morning!

I have a hypothesis: I do not know the Godox T685, but how does it measure how much power that it needs to emit? Presumably by measuring how much is returned/bounced from the object. Could it be that your modified softbox covers the TTL “eye”?

Have fun!
Claes in Lund, Sweden

1 Like

Isn’t TTL supposed to measure light Through The Lens?

But if not, that would explain why TTL always produces over-exposed images.

However, my main issue is why it won’t stay put in Manual mode.

Isn’t TTL supposed to measure light Through The Lens?

Yes. If lens, camera, and flash can communicate with each other.

What if the lens can’t communicate with camera?

Then it is not TTL. In those cases, the flash has to decide when the object has been properly lit. And if the “return light receiver” is covered, it will have problems.

Another hypothesis, regarding your second problem: I believe that your flash goes into idle mode after 90 seconds of inactivity. Perhaps it is set to start in TTL mode when it wakes up again?


I don’t know the Sony, but on my Canon, when I am in aperture or speed priority (A or S modes for you it seems), the camera considers that the flash is just for fill-in: it will correctly expose for ambient light and assume I know what I am doing with the flash. Flash TTL exposure is really only for P(rogram) mode.

1 Like

I’ve seen this same behaviour with Promaster flashes (although not on a Sony body) - the flash reset to “default” after interaction with the camera, and never gets TTL right. Most budget flash manufacturers do TTL by reverse-engineering (because camera manufacurers either won’t release the specs or want to charge an arm and a leg for them) and their TTL isn’t 100% reliable.

Sometimes the problem shows up on newer camera models, after the camera manufacturers tweak their protocol. The Promaster I mentioned had a firmware update that fixed the issue with newer bodies. If there is no flash firmware update, see if you can borrow flash a Sony brand flash - if TTL works reliably with that then it’s a problem with the Godox. If it exhibits the same issue then you’ll need to have the camera serviced.

Answering the question not asked: Go back to M and use a remote trigger to fire the flash - your pictures will be better since you can control the direction of the light. It will also give you the option to ditch the diffuser (for macro work, a flash head by itself large enough to provide soft light.)

Firstly, I was never able to get a soft enough light with a naked flash. Secondly, and I’ve tried this approach a few times, using a wireless trigger and an off camera flash, although very efficient as far as lighting direction and quality is concerned, is very, very uncomfortable for me.

The way I shoot is by using my left hand to stabilize the subject and the camera, so I would need a third hand to be able to confortably shoot with an off camera flash.

Well, it is very easy to test if my ideas are valid for your setup or not.

a) Hypothesis 1: your softbox covers the receiver.
Remove softbox and see how the flash behaves.

b) Hypothesis 2: going idle after 90 seconds of inactivity.
Observe settings (with softbox off) when you become active again.

For the record: there are many varieties of “TTL”. From good old
analogue TTL to digital TTL, eTTL, eTTL II and so on, mostly depending
on what the manufacturer thinks.

Have fun!
Claes in Lund, Sweden

1 Like

I don’t think it’s to do with resuming from idle, since it happens immediately after being triggered. I’ve just had this happen: the flash fought me over M mode lol. Had it in TTL and when I press the Mode button to switch to M, it will display M on the LCD for a fraction of a second, and not actually make to to M.

Do you have a second flash? Any way to guarentee this one isn’t faulty?

No to both your questions.