Help needed with updating DT from 3.8 to 4.2 flatpack (resolved)

Please be gentle. I have spent the last couple of hours with Dr google trying to resolve issues with Linux Mint. My Windows laptop died last night mid keyboard stroke. So today I dug out my desktop computer with Linux Mint installed. However, it has DT 3.8 on it and for the life of me I can not work out how to upgrade. I thought going to the DT install page and selecting the flatpack option there would be straight forward. But all that happens to me is that it installs a file named org.darktable. Darktable.flatpakref. When I run this it just offers to install dt3.8. What is this linux beginner doing wrong?

If you’re using Mint 18.3 or newer then flatpak is supported by default. I think that version is fairly old, so if you’re on something older than that, you should probably upgrade.

  1. Open a terminal
  2. Enter flatpak install flathub org.darktable.Darktable
  3. Enter flatpak run org.darktable.Darktable

Darktable should start.

@paperdigits thanks for your response. That didn’t work for me, but I solved the problem on my Linux Laptop by first deleting DT and then getting it to install and it now has DT4.2. I am currently in the process of installing DT on the desktop with slow internet so hopefully it too will update. Linux can be a strange beast to a Windows user, but I hope to get use to it.

Glad its working.

Just to clarify for anyone else reading this post that may experience a similar problem, do I have to manually delete the old version of Darktable before installing the new version? DT 4.2 now installed.