Help with display of CR2 images

I am new to Darktable, and I have imported my first images in CR2 format, using windows. In darkroom, I observe that the right half of all pictures displayed are shown with coarse pixels. In the attached screen snapshot, take a look at the upper right ridge of the small mountain, illustrating the issue. The display mode is “fit”, and the coarsening vanishes if I zoom. This may be an installation issue / graphics card issue, but I would appreciate all suggestions for fixing the poblem.

Hej Tor & welcome!

darktable version?
Could you share the .CR2 file?

Have fun!
Claes in Lund, Sverige

Hi Claes, thanks for a swift reply! It happens to all of my CR2-files. I import by drag-and-drop into the lighttable. Here is an example file.
IMG_6893.CR2 (23.8 MB)

What happens if you just open the file… go to import… add to library and open it…?? I have no issues on my old PC at work opening it…what version or DT?? What if you disable opencl…

It opens just fine for me in dt 4.4.2. I open it via the lighttable - add to library button, though. I don’t think I’ve ever tried drag and drop.

Works for me with DT 4.4.2. Quite an interesting photo…
Works for both drag-n-drop as well as the “add to library”.

IMG_6893.CR2.xmp (19.2 KB)

1 Like

I just tried both and it was fine… however one thing this image presents for me is, and I feel like I have seen this before with canon images and maybe even it was from this camera model that they are not sharp. I wonder if this is how it looks when a much higher res image is scaled in DT to my std HD monitor. I should look at it in another program but the image for me is just overall very lacking in detail almost blurred and I wonder if it is happening from down scaling??

Could be just sensor resolution & therefore, perceived detail? The EOS 7D features an 18.0 Megapixel APS-C size CMOS sensor. The image to me looks OK - the focus point I would guess is slightly less than a third from the bottom of the frame? The blades of grass seem to be more distinct at about that plane - the rest being taken care of by the DoF at f/13.

Therefore, I don’t think adjusting the sensor will change the perceived detail. However, if the OP wishes to do so - instructions here: how to calibrate the canon 7d for accurate focus

1 Like

Well this was one comment from the video you linked …so maybe it can be an issue … I just figured it was how the preview was being handled…

“Still works 2022, on my 2nd hand 7D that was so soft I almost threw it in the trash. Im amazed anyone used my camera feeling it was ok. I ended up -14… Thank you!”

Thanks to all for replies, which unfortunately not have brought me any further. Except that hearing that it loads OK for others, makes me suspect this is a darkroom/pc hardware problem. The image looks fine in Canon’s own Digital Photo Professional 4 and in the default Microsoft image viewer. I have now in vain tried various graphics setting on my HP pc (with AMD Radeon HD 8650G). My graphics driver is up-to-date. Changing the way I import images into darktable does not help. I have yet not found out how to disable OpenCL, so advice will be appreciated.


activate OpenCL support

1 Like

Deactivating OpenCL fixed the issue. I am now ready to proceed to understand all options… User support so far has been excellent, so thanks to everyone for quick replies and great help!


Are you using the drivers from the AMD website?

No, the driver seems to be delivered by Microsoft - and checking again it seems to be fairly old - 2006. It is windows that tells me it is up-to-date. Scanning the AMD web page, I am not able to find the 8650G in the driver list.

Also make sure you disable Windows opencl compatibility drivers (sometimes installed by default)

1 Like

I have now updated the driver to the 2016 version, and the image displays perfectly both with and without OpenCL enabled. Maybe I should buy a newer pc… Anyway, thanks again for patience with a novise user and for great help! I am looking forward to playing with the application.


IDK. It looks absolutely fine to me. This isn’t a Play Raw, so I’m not sure if I should post my edit.

1 Like

I think we should be respectful of the original scope of the post. If OP wants to make a Play Raw, they certainly can.

I agree, and I did not try to treat this post that way. Maybe I didn’t say it well, but I was trying to say that the image converted very well for me and also it seemed to be a clear, good image, but that I shouldn’t post an example of what I saw, because of the thread scope.


The issue was resolved. Old OpenCL drivers rendered the image incorrectly.