Highlight Bloom and Photoillustration Look


(Mac Lo) #41

in G’MIC 1.7.9 the direct G’MIC commands return an error:Unknown command or filename ‘–gimp_anisotropic_smoothing[0]’.

Is it OK to replace ‘–gimp_anisotropic_smoothing[0]’ with ‘–gimp_smooth_anisotropic[0]’?


(Pat David) #42

I would think so, though I’ll defer to @David_Tschumperle to be sure.


(G'MIC staff) #43

Yes it is, the command has been renamed in latest version.


(Mac Lo) #44

thank you :slight_smile:


(Przemysław Wollenszleger) #45

Hi guys
I’m trying to replicate this and I simply cannot due to an mysterious problem…
When I try to do some local contrast, even with this example photo, I got some strange squares:


Software: Gimp 2.8 with g’mic 1.7.9 on linux mint machine.
Any suggestions anyone?
Wish you guys merry Christmas :slight_smile:


(Pat David) #46

I would turn off the Parallel processing. That’s what is causing this problem most likely.


(Przemysław Wollenszleger) #47

Thank you Pat, it helps :slight_smile:
So, I can show you my 1st attempt:
Before:


After:
I think few more photos, more experiments and the effects will be great :slight_smile:
Thanks a lot :slight_smile:


(Sebastien Guyader) #48

This one is pretty neat!


(Sebastien Guyader) #49

Here’s a script-fu for the complete workflow:
hillustrative.scm (2.6 KB)

It works fine in Gimp >= 2.9, if it doesn’t work in lower Gimp versions please try this one:
hillustrative-2.8.scm (2.6 KB)

This is my first script, I hope I did it correctly.


(Mica) #50

Can I add these to our script repo?


(Sebastien Guyader) #51

Sure if you can confirm the script works.


(Mica) #52

I’ll give it a go when I get on my laptop in a bit!


(Boris Hajdukovic) #53

Hi sguyader,

I’ m using GIMP 2.9 and getting following error:

“Procedure execution of plug-in-gmic failed on invalid input arguments”


(Mica) #54

Both scripts are working for me, I’ll add the 2.9 one to the repo!


(Mica) #55

Added your scripts here: https://github.com/pixlsus/GIMP-Scripts/commit/febbcab00df8537a9508fff5853fb766e5739f49

Thanks!


(Sebastien Guyader) #56

Hi Boris,

I guess you have the G’MIC gimp plugin installed? Which version do you use?


(Boris Hajdukovic) #57

Yes Sebastien, I’m using G’MIC plugin Version 1.7.9.


(Sebastien Guyader) #58

I’m still using version 1.7.7, maybe something has changed in the more recent version, but I’m not a G’MIC / script expert… I hope someone more knowledgeable will chime in.

In the mean time, I added another step to my workflow, which consists in a tone mapping step (-gimp_map_tones_fast 15,0.5,11,0) at the beginning of the workflow, which exagerates the illustrated look. Here’s the new version of the script:
hillustrative.scm (2.7 KB)


(Sebastien Guyader) #59

@s7habo Boris, I ran into the same problem by updating to G’MIC 1.7.9, it happens because the -gmic_anisotropic_smoothing command has been renamed to -gimp_smooth_anisotropic.

So with G’MIC >= 1.7.9, please use the following script:
hillustrative.scm (2.7 KB)

If you think the latest change I made (adding the -gimp_map_tones_fast step) is too strong, you can either comment line 13 in the script, or tweak the settings for this filter.


(Boris Hajdukovic) #60

@sguyader Wow! It works now. Sebastien, thanks a lot for script, help and for clarification!