History stack keeps disappearing

So my history stack is resetting every time I click back to lighttable. I really love Darktable but this makes the program pretty much unusable. It was working before, and it just started doing this. I uninstalled & reinstalled twice. Still doing it. Anyone ever have this problem?

Hi @Bronson and welcome!

a) operating system?
b) darktable version?
c) from where did you obtain it?

2 Likes

No, you’ve the first to report. A problem on your side and will need far more details as @Claes asked.

1 Like

Windows 10 64 bit, 8GB ram, Intel Core i5-3337U 1.8GHz
Darktable 3.2.1
From Darktable.org

@Bronson Is it possible for you to record a small screencast to show us the problem you have? You might use https://screencast-o-matic.com for recording and then uploading the file to e.g. http://filebin.net or share it in Google Drive or similar.

2 Likes

Sure I can do that

Here’s a link to my google drive with the video


Sry for the sounds, haha, my cat has a water fountain.

Thanks! That will probably help @Pascal_Obry or other darktable experts to know more about what is going on.
From a first glance it looks as if you have a writing permission problem so that the xmp sidecar file is not stored alongside your image - but I may be entirely wrong here.

1 Like

Yes, most likely.
It happened to me that due to side effect of a Windows update, the configuration folder become read only and DT couldn’t write to library.db

@Bronson I suggest to check you have write permission to files in C:\Users<your name>\AppData\Local\darktable

Yeah, I do ok with technical issues but this one is beating me. I downloaded RawTherapee to hold me over but I really love Darktable. I really appreciate you guys helping out. It means a lot.

Not sure how to do that but I can google it

@Thanatomanic @MarcoNex Not sure if this video helps give insight but I had it installed on my 2nd internal SSD, so I uninstalled again & tried to reinstall on my C Drive.
But this happened:

Do you have check for new xmp files set to true…that may stop the database from reverting it until you get the other part sorted…its in preferences

I’ll check

Or you can copy your config files to a new directory and start DT with -configdir pointing to that directory…I run it that way anyway to keep my config files separate from a running version as I update frequently

Ok, I found “look for updated xmp files on startup” & checked that box. Still not working. I’m looking thru settings now to see if I can mess with the directory

Your best bet then if it is a permissions thing is to use configdir command line switch

1 Like

Two ways you can try to do this to confirm where your issue may lie…if you create a new dir and then use --configdir “path” it will create fresh db and library…they will be empty but you can import a file or two to confirm it works fine…okay now you know something is up with your config files…copy them in to that directory…overwrite the other ones created by DT and try …now your config files are in a new dir and likely no permissions issue…if it is still messed they must be corrupt?? Thats a terse explanation but basically you are just modifying your shortcut that runs DT to use that command line switch

1 Like

not sure what that means but I can look it up

So if you are on windows your DT runs from a shortcut…pointing to program files/…/…/bin/darktable.exe…so edit that and add --configdir “your new folder path” in quotes and then run…make sure to create the folder…DT will create fresh config files…test that first then if okay copy your files from their location in Appdata

2 Likes