Hitting potholes and roadbumps in using darktable 4.2

Thanks to help from several on this forum I thought I was making good progress, cruising actually, in processing many pictures and converting them to B&W. I’m using darktable 4.2 in scene-referred mode and seeing the benefit of the sigmoid module.

That said I was too premature in thinking I was able to make my way around darktable. Below I list three problems that have blocked me completely. The manual, excellent in other regards, isn’t of any help in this matter. I’ve even reinstalled darktable expecting that’d get me over the potholes but that didn’t help either.

Issue #1:
I’d process an image, go into lighttable, export, double-click on image, see the “film roll” at bottom of darktable window, click on next image to process…
After successfully doing that with several images I found facing not the next image but darktable’s gray middle panel that says there are no images in library, nothing to view/process, etc. However I had already added a library earlier and processed a subset of images and am ready to process the remaining. I can’t see the film roll at the bottom of darktable window, etc.
If I try to add the same library darktable says the images are already added. However I’m not able to see them to continue processing them.
Were I to close darktable, restart it, or reinstall it and try the same library darktable puts up the first image in the library with crazy artifacts. See screenshot.

Clicking on that image doesn’t open up the film roll at the bottom like I had when I was originally processing the images. I can’t see the other images in the library.

Per the screenshot the “Raje Set 2” had 153 pics. I’ve successfully processed about 50 already. I hit this snafu while about to process the 51st image.

Did I do something wrong? Did I click on some tab or icon that threw me into this situation? Is this a known bug? Can I go back to where I was and continue processing the remaining pics? How do I do that?

Issue #2: issue is the fact darktable no longer recognizes pics taken by my 55mm Nikkor 2.8. It used to. Now it chokes on Lens Correction on every image taken by that lens requiring me to manually pull up the list of Nikon lens and choose the 55/2.8 before proceeding with the other processing. Is this a known bug? What is the workaround, if any?

My appreciation for your comments and help.

p.s. kudos to pixls.us for maintaining drafts of the posting. I was about to send the above, the mouse and keyboard froze, I had to reboot…had given up on typing everything again but was delighted to see pixls maintained the draft intact! I believe darktable is at the root of the mouse./keyboard freeze. Earlier versions of darktable caused the same issue…I thought I might be over that with 4.0 and 4.2…but perhaps not…for what it’s worth I run Windows 10…That’s issue #3.

Most of this is explained in the manual. Since you are using 4.2, I will link you to the draft version of the 4.2 manual (sorry it is not finished), but most of this info has not change in a while.

First, reinstalling doesnt solve problems. Most of the important files are stored in the configuration folder so you can keep your settings from one version to the next.

  1. In the bottom of the screen, there is a small white arrow pointing down. Keep clicking on it to cycle thru multiple view options. The view options apply differently to lightable and darkroom views. Right now you are seeing the timeline view. It shows a histogram graph the the amount of images taken per year/month. I dont think it is useful at all, so keep clicking to not show it.

  2. in that view on the bottom right side, the second button from the right is focus peaking mode. You have it on, so it tries to show you the with the color the areas of focus. Just click the button to turn it off.

  3. I suggest you switch to folder in the collection module. This will show the images in a tree structure that more closely matches your file system folder structure. This will simplify navigation instead of the filmroll approach.

  4. You have the file manager view set to 1 image (at the bottom bar). I suggest you keep this at 4-5 to see all of your images. If you need to see an image larger, you can press+hold W to show the image that the mouse is hovering at OR press F to turn on the Full screen view. Press F again to turn to normal.

I dont know about the lens issue. Maybe it needs a lensfun-update-data



Is there something akin to reset to defaults in DT… I guess running it with a new empty config file is the closest… I think the UI might benefit from something like it… This is so common. People start clicking on things and don’t notice and then end up thinking the program has been damaged corrupted or otherwise when often its a simple thing that they are just unaware of… especially when they mess with filters and filmrolls and think their images have gone…

I’m not sure what this would look like or how exactly how you would implement it but maybe being able to save a default layout at a time when things are working and or even from the very start as something you could reload if things get messed up… just thinking about how often this seems to happen

Count me as Exhibit #1 for that!
There are so many tiny buttons and icons…and sometimes it takes a while to process an image…and during that time were I to inadvertently click somewhere, even if it be in the “Gray Areas”, I find myself thrown into a darktable-whirlpool…

The good news: everything is done in a “non-destructible” manner so I’m confident nothing is corrupted. Yet these glitches make hearts skip beats and hair torn out…and of course, the tenacious reach out to seek help here…

That said, I’m back and running with g-man’s suggestions in response to my Qs. I shall look into lensfun-update data. I still walk on eggshells worried about the mouse/keyboard freeze…

Mouse/Keyboard freezes, unexpected behavior in apps, are you sure your computer is OK? Are you experiencing frequent unexplained crashes, too, of all kinds of apps?

Such things can be symptoms of a hardware defect. I had a defective stick of memory once, and it felt like my computer had had a stroke. It was really eerie. If it only affects darktable and maybe the browser, it could be a GPU issue as well.

Yes there is. On Windows go to:

  • C:\Users\<username>\AppData\Local\darktable - Zip and backup the files, then delete these: darktablerc.txt, data.db and library.db. You likely can keep library.db, but I’ve never try it that way.

Doing this delete will give you the interface you have as a fresh start. If you maintain your images/xmp in an organized tree structure, then Add to library recursive and you get all of the images back in a couple of minutes. But to me this is the nuclear approach and I dont think it is needed.

No I dont think there is an easy way to do this via GUI. A lot of the values change with each version of dt, so I think it would not be that feasible.

darktable already does backups (snapshots) of the two databases at a frequency (per your settings). You can restore to a previous version via a rename.

1 Like

are you sure your computer is OK? Are you experiencing frequent unexplained crashes, too, of all kinds of apps?

Yes, I’m 100% confident–and I say this with over 30+ years experience in the tech world–my computer is OK. I’ve not experienced a mouse/keyboard freeze except for when I use DT.

This was more frequent with prior versions of DT and prompted me to step away from DT. I briefly tried RawTherapee. A couple years or so later, I drifted back to DT. With DT 4.0 I thought perhaps the bug was resolved…but ran into it yesterday again.

The only option at all times was a hard reboot, nothing less.

Additionally, whereas the old DT recognized my 55/2.8 the new doesn’t. The lens is described differently so I have to manually choose the new description for every image taken by that lens. I wish DT retained the old description so it can use the new or the old to recognize lens. On my task list: lensfun updates…

Ya this is what I meant…not even taking all those steps just running it with a new configdir…but it would likely be nice to be able to save the UI layout not everything, just that and then be able to do a reset easily to that point

You can create an auto preset to match that lens and apply what you want then that lens is used…