Hmmm.... this might be a fun little lens

The photo is no work of art (it’s misty / rainy today so I’m inside) but I like this f/1.7 lens, at f/1.7…

I took this with my Canon T8i / 850D and a Ricoh Rikenon P 50mm f/1.7 SLR lens via a Vello K to EF-S adapter. The biggest challenge is focusing. On the Ricoh XR-P body* there’s a split screen, but not on my DSLR. So I’m using Live View and 10x magnification quite a bit. I guess I need to embrace the imprecision…

* Speaking of which, does anyone know how to un-hang the shutter? For some reason it’s become hung about 10% open, mirror up and the crank won’t advance. I’ve tried everything I can think of short of disassembly, but to no avail.


CAn’t help with you hanging shutter :man_shrugging: Sticky apertures, yeah… but shutter, no experience.

But seeing this picture, I was reminded of my old laptop from 2002 (I think), it’s still running btw, had it up until recently, even on my work.

To keep this at least a little bit relevant, I shot this with a Minolta MC Rokkor 55mm F1.7 at 1.7

Hope you don’t mind the little highjack :slight_smile:

And yeah, I like (especially the older ones) with a soft open aperture.


Discounted Mitakon focal reducing Minolta SR to M4/3 adapter I ordered is arriving today. Wanted to try some some manual and zone focusing, though I’m not sure if or how the distance measures on the lens would be affected by the focal reducer/crop sensor combo

Ouch! It might be the shutter … but it might as well be in the mirror chain, so to speak,
they sort of cooperate. @difrkaguilar

1 Like

I have not had the opportunity to work with or handle any Ricoh XR-P but it seems to be a common problem with these cameras. I found a post on DPreview where a user has a similar problem, where the shutter is stuck.


Yeah, I’ve found several similar posts here and there. When I first got the camera, the batteries were dead. The shutter wouldn’t fire and the crank lever wouldn’t move past stand-off position. I learned the shutter is battery dependent, so I put new batteries in it. The meter works, etc., but neither shutter button fires. The “grip” button makes a very faint ticking sound but that’s about. Timer / interval button works, apparently, or at least tries to.

Actually the mirror was working fine and I had the lens off the other day (not the first time I removed it, BTW). When I went to replace it is when I saw the mirror had flopped up (spring loaded, can be pushed down but won’t stay) and the shutter was partially open. Dunno what caused that unless some button push tried to fire the shutter and it hung.

I’m going to remove the bottom plate and take a look, per this thread. We’ll see if that makes any progress.

At any rate, I really don’t plan on shooting film, but nonetheless I’d like the camera to work, know what I mean? :slight_smile:

1 Like

Nope. There’s no such “lever” as referenced in that thread. I read somewhere that if a motor drive was involved it needed to be attached, which this camera has. I attached it, but no joy.

Oh well… I guess it’s irrelevant whether the camera works or not since I’m not using it. Back in the case it goes (sans 50mm lens).

Stupid question, but still: did you have working batteries in the drive as well?

Yes, and the drive works. But the shutter never moves unfortunately. :frowning: