How can I restore my landscape text not go to opposite direction?

Hi, I am using Gimp 7.0 and I was trying to input my text into a landscape layer, the text just showed in the opposite direction.

The other issue is, that the text is just having a big space between.

Finally, the toolbox has not shown the full set of button when I installed this software in the beginning. I went to edit, preference and reset the saved device setting to default value but it could not work.

Please teach me how to solve my facing problem.

gimp 7 tool box

Hi @PeteThompson, and welcome!

A few questions:
Gimp 7.0?
From where did you obtain it?
Operating system?
Do you use a pen/tablet or a mouse?
Please post a small .xcf showing your problem.

Most probably it is due to your gimp-text-editor-dialog
settings. See the Gimp manual for more info.

Have fun!
Claes in Lund, Sweden

First thing is open the tool options tab, that tab on the extreme left (under the toolbox)

You have a long fixed size text box, and selected text, Gill Sans size 36. Always suspicious when a new Gimp user has selected text, often means that the original text was something else.
I recommend clearing the formatting using left-pointing arrow icon on the text tool. Then if you want Gill Sans 36px set that from the tool options instead of the on-canvas tool. While there check for any strange spacings / indentation values

Want the text on the right-side of the text box ? Right click to bring up the orientation options and choose the ‘From right to left’ option.

In my opinion a better way is swap the fixed text box to a dynamic text box in the tool options and move the (now small) text layer into position on the canvas.

Sounds complicated, not really, 1 minute demo of all that.