How can I switch to full English version of digiKam?

I’m puzzled… :question:

I’m using Win 10 Pro in the English (British) language version.
I use all my applications (like browsers, Adobe products, MS Office, etc.) in English. Only my keyboard settings are ‘United States International’ with Dutch preferences (so; NOT a Dutch keyboard, but US international layout)

BUT… digiKam mixes some Dutch words into its menu’s. How come? And can I get rid of this behavior?

See screen dump:

Almost everything is in English, as it should be, but some text is still in Dutch?!?

I’ve tried digiKam 6.3 and the latest 6.4 build. No difference…

This explains how QT is using language settings

Setting LC_ALL and/or LANG to “C” will usually fix it.

And this explains the pains of doing so under M$ DOS

1 Like


I’ve first tried setting set LANG=C in a command (admin) window and checked the value, which was confirmed. But this didn’t have any effect.

So I’ve set it trough the Control Panel/System Properties/Advanced/Environment Variables and added the LANG variable with Value C.
And that worked!
Now digiKam is full English; thank you.

1 Like