How do I get Crop to errr well, crop?


The manual states “There is no need to “apply” a crop - it takes effect the moment you draw it.” It doesn’t. I can still see the bit I want cropped out. How do I get it to go away?



That fooled me for awhile because it still shows the area you’ve cropped off. If you save it and reopen you’ll see the cropped area only.

(Sebastien Guyader) #3

If you work on raw files, RT doesn’t modify the file itself, it only shows the area which will be cropped. When you reopen the file, the crop area will be displayed again because the raw file is not modified. When you export to jpg or TIFF or PNG, the output file will be cropped. The advantage of this is that you would always be able to adjust the crop area by simply dragging the borders. I think most raw converter act this way, at least it’s not something never seen before.


Photoshop Elements 9 does!
Mostly I crop stuff out because it looks distracting, so to still see it, is distracting.
I’m sure it can be done easily without saving to file (which I don’t want), given that you keep a complete history of what has happened since the crop.

(Sebastien Guyader) #5

Photoshop elements is not a raw file editor.

(Ingo Weyrich) #6

If you don’t want to see it hit 9-key :wink:


Which 9-key? I’ve tried various combinations without effect.
(Using Mac OSX 10.9.5)

(Ingo Weyrich) #8

Maybe there’s an Issue with Keyboard shortcuts on OSX. But this one should work


Simply go to preferences and change the “Cropped mask color/transparency” to no transparent and the mask color to the backckground color. :slight_smile:

(Andrew) #10

I’m not keen on the default rule of thirds guide lines, but I found a way to semi-permanently stop them if anyone wants to know…


Hitting 9 solved all my problems! (On Linux)

(Richard Wonka) #12

so there is a need to apply the crop and it gets applied by saving and reopening?

(Karlheinz Lehmann) #13

No, with the 9-key you control what you see after cropping.
The topmost setting uses the transparency mask from the gui settings, the middle settings adds a black frame, the bottom setting uses a white frame. And this setting works immediately.
The left button shows the original size maximized and the right button shows the cropped area maximized.

When you work on a raw file the original file is not changed and the sidecar file is used on reloading to reapply the changes. If you work on a non-raw file like a jpeg, the cropping is indeed applied to the file on save and you are no longer able to revert to the original settings.