How do I process AVI RAW8 planetary video with Siril?

I captured AVI files using ASIAIR Pro and am attempting to process them with Siril 0.99.10-1 on Mac Big Sur.

The video format is AVI RAW8 which contains color information but looks like monochrome. Siril is converting it to monochrome with a visible grid over it, because it is not debayering the format properly. I have tried selecting both .SER sequence and FITS images in the Conversion tab’s destination, and tried with and without the debayer checkbox, and gone into the debayer preferences but did not find anything that looked like the right option.

Is there any way to convert these AVI files properly with Siril? Alternatively is there another format I can convert the AVI files to that will be properly imported by Siril?

(And apologies - on my first try I somehow posted this outside of the Siril part of the forum).

Hi, if adding the avi file to the list of the files to be converted, selecting a SER output and activating the debayer checkbox doesn’t work, that’s probably a bug. For me that’d be the right way to do this import.

The preferred way to do the acquisition would be to use directly the SER format, which was created for astronomy, contrary to AVI that can contain any type of data and doesn’t have all the required information. See SER - FreeAstro for more information about the two formats.

I don’t think so. Debayer is not dedicated to AVI files, it won’t work (no bayer information).
As you says, one need to convert first to SER file and then, force the debayer.

debayering is just an operation on image data, it could work on this too, using the Bayer matrix information from the preferences. It’s the same as forcing a monochrome (not CFA) SER to be debayered (is that actually possible?)

Yes but we do not develop any code related to AVI :).
This is why we encourage to convert to SER.

Here, it should be (by unchecking the “read header” button). If not, this is a bug :).

Thanks @lock042 and @vinvin.

I set my preferences as follows:

  • Bayer information from file’s header if available - OFF (I have also tried ON)
  • Bayer/mosaic pattern - RGGB
  • Debayer interpolation - RCD
  • Debayer FITS files in top-down if no explicit keywords found - OFF (I have also tried ON)

And then in the convert dialog:

  • SER sequence
  • Debayer ON and OFF (tried both)

In all cases I got a monochrome result with the faint grid over it. In the case of Debayer OFF in the convert dialog, the preview only showed half of the picture, the rest was black. In the other cases, the whole field of view was shown.

I understand that .SER is Siril’s native format, and would be happy to use it if I could. The ASIAIR Pro and ASI 462 can only create 3 options: MP4, MP4 + AVI RAW8 or AVI RAW8 only. I was capturing MP4 + AVI RAW8. I have successfully processed the MP4 with Siril into a color output, but obviously this is losing most of the detail that was captured in the AVI.

Are you saying that Siril should convert the AVI RAW8 to SER but does not due to a bug? Or that I should somehow convert the AVI RAW8 to SER before using Siril? I’d appreciate any suggestions you have either way. If it’s a bug I’ll be happy to test any fix for it.

I can confirm we can’t force to debayer SER file. So here, this is a bug I guess because it works with FITS.

Reading the code in fact we never handled this case.
We assume that header of SER file is always true.

OK, thanks for investigating. Do you plan to fix this bug? And do you have any suggestions for me to convert AVI RAW8 to SER on Mac?

You can convert to FITS file, it should work.

How? I have now tried “FITS images”, “SER sequence” and “FITS sequence” in the Convert menu with and without the Debayer checkbox. Every time I get the monochrome result with the grid. With the Debayer checkbox, the lower half of the image is black. I have not found any combination that debayers the file properly.

Convert your video in FITS, then after that you will be able to debayer your FITS.

We’ve pushed a fix that should be available in the next release

1 Like

Thanks so much! Looking forward to trying it out.