How to export a transparent png

Every time I try and export a png with a transparent background it looks weird.
in GIMP the background is transparent but when I export it, it looks like that.

I have no trouble exporting PNGs with transparency on my Windows 11 computer. I also use TIFF format for this. I wonder if a scene shot of the dialog window that opens up when exporting as a PNG might be helpful to understand your problem. You may have something selected causing this problem. The settings shown here worked for me.

What you see displayed does rely on the Image viewer used. Not all are the same. The transparency is just an alpha channel mask and not working in whatever application you use.

In Gimp try an experiment. Use the eraser tool and put it into anti-erase mode (alt key) . Now erase some of the transparency. What do you get?

Usually the solution is to untick that Save Color Values…in the png export dialog. That will give a solid mask. Still might not be what you want in your application but it will be solid.

Is your image indexed? There’s a bug in the current version of GIMP that causes issues with indexed transparent PNGs. It’s fixed for the next release, but for now export as RGBA instead (you can change the image mode in GIMP, or choose RGBA from the pixel format dropdown on export).

cmyk.student will be the answer, however in my kubuntu 20.04 / Gimp 2.10.36 I get this heads up that not all is good. So a scrabbled image should not be a surprise. Is that message only linux or is it all OS ?


Use Imagemagick and a RGBA png.

magick image.png +dither -colors 256 -background black -alpha background PNG8:output.png