How to install Darktable 4.0.1 in linux Mint (ubuntu derivative)

I know there are new versions but I would like to stay with darktable 4.0.1 due to some compatibility problems.

I was trying to find binaries for ubuntu to install in my new linux Mint install (I was previously using windows).

I could find a deb package in OBS (in the opensuse distribution under ubuntu).

Thank you

But when I try to install it using ipkg I get errors complining about some libraries not present like libicu71 and others.

When I try to use apt to install that libraries it complains that the libraries cannot be found.

I suppose it is due to that libraries being substituted by others in the repositories for the new versions os ubuntu (I am using linux mint Vera, similar to ubuntu 22, I think).

How my I get that libraries installed or how I may get darktable 4.0.1 installed in my system?

You’re going to have a bad time trying to get a deb package built for a different distro or version of the same distro installed.

Your best bet is likely to check out the source code for that version and run the build script. Or find the flatpak for that version and use that.

1 Like

Ok, thank you I was having a bad time trying it already.

Does the tar file that is in GitHub for that version include the sources to the dependencies?

If not it would be difficult to get it working and find appropriate source versions

Flatpak would be a good solution, but I could not find the appropriate distro.

It seems in flatpak there is only the last version.

It contains rawspeed, but the rest of the dependencies are on you. There are quite a few of them.

If you can build the flatpak yourself, you can just change the json manifest to point to the version you want. Or you can I stall the latest flatpak and try to roll back the version.

1 Like

I’ve never tried it, but it looks like you should be able to use the command line flatpak tool to find and install older versions of software from (for example) flathub.

This link explains the commands a bit.

Do you have flatpaks working and have you gone through the steps to add flathub to your system? I don’t know what Mint does out if the box and want to make sure we can answer your questions if you’ve recently switched from Windows, apologies if you have more Linux experience.

With flatpak and flathub set up it looks like the first command would be

flatpak remote-info --log flathub org.darktable.Darktable

and find the commit you want from the list.


Just curious…so much to gain esp in highlight handling if nothing else…what are the roadblocks to going with a more current version??

Thank you all.

Not enough experience in Linux to compile darktable and all the dependencies.

It seems there may be older versions in flatpak, I will try that.

In the web there is no other version, but it seems there might be more that can be listed as you say, using the command line I will try that.

In flathub they say they do not guaranty storing old versions for many time.

Is there a way to download the distribution file and store it locally for future use?

(I have only used flatpak once in Linux mint to install displaycal and it was using the app manager gui)

Well thank you @BorisRabit for your hint.

I could install 4.0.1 using flatpak command line.

the commit for 4.0.1 is: ffe32b5c29648562b2c400c4bf3df2832ca165a216ea6292e5a741f7e353955b

But I could not installed it directly, I tried

sudo flatpak install --commit=ffe32b5c29648562b2c400c4bf3df2832ca165a216ea6292e5a741f7e353955b org.darktable.Darktable

But I receive an error, it seems you cannot use the commit option to install the version you want you have to install first the current version and then downgrade to the commit you want, like this:

sudo flatpak install org.darktable.Darktable
sudo flatpak update --commit=ffe32b5c29648562b2c400c4bf3df2832ca165a216ea6292e5a741f7e353955b org.darktable.Darktable

That way I could install 4.0.1 version.

What I don’t know is how to download the files in order to keep them and install them locally (just in case the commit disapears from flathub soon).

I’m glad I was able to help in some way. :slight_smile:

Ideally, I think the community would be interested in knowing what was giving you trouble in the newer versions of darktable. You said “compatibility problems”? If you were to start a new thread specifically for that topic, people smarter than I am may be able to help, or even fix issues for other users too.


Just don’t want to upgrade the database, I am testing Ansel and it uses the same database as 4.0.

For the moment I don’t need new improvements in 4.2 and would like to simplify and don’t maintain two databases.

It surprised me how difficult it is to install a given version of a program in Linux.

In windows installs use to be easy, just download the installer you want and execute it

I was using Linux for decades but not for desktop use, at server tasks .

Now I decided to go the Linux way for everything, at least all as I can, as there are some windows dependencies.
Not easy to adapt all the knowledge but given the paths that windows is going ( the Google big brother path) I won’t return.
A pity I can’t do the same with android in the mobile.

1 Like

Windows has only a few versions, for Linux there are a lot of distributions, each with their own combination of versions for different libraries…

That said, the darktable source can in principle be compiled on any distribution, unless some of the libraries needed are too old (and then you can try to compile newer versions).
You will have to install all needed libraries though, with the corresponding development packages (through the package manager for your distribution). Either you have a list of the dependencies, or you can use “trial-and-error”:
start build, on error install missing dependency, and repeat until build completes.

If you get errors about missing symbols, you most likely have a version mismatch somewhere. Those are a bit harder to handle.

Any decent package manager will list the dependcies for you.

At any rate, software is difficult, hopefully there is some new found appreciation for it :slightly_smiling_face:

I had not read answers till now. Thank you.

All version dependencies of librariescis something that the installer (package manager) should take care of, no the end user.

Compiling is something that only a developer should be aware of, not the end user.

Apt does a great job installing dependencies and managing packages.

The only problem is that all the system seems to be thought mainly for upgrading to last version and repositories don’t seem to keep old versions.

Each major version change in the OS changes the repository so no old version there.

Flatpak does not provide an easy way to install an old version.

In windows all the process is done by the installer you only need to get the old version installer from somewhere, no repository there except for drivers and os files.

Usually you can install a windows xp program in windows 11 wothou problem except if it depends on some deprecated os functionalities.

Anyway installing old versions is not something you want everyday.

For what I needed the flat pack solution was enough, thank you.

You probably are aware, but for the benefit of others; Ansel recently seems to have introduced new, presumably incompatible, module versions so the way back to dt may not be guaranteed.

“testing” Ansel vs an old version of dt has its limitations. The choice is not so much a technical as a philosophical one; do you consider 4.0 “complete” and are you willing to live with the choices of one maintainer (both in what is necessary to fix/improve and what is useless and can be removed) or do you want to benefit from the efforts of a larger group to fix, improve, optimise and extend the program, at the possible cost of (temporary) upheaval and directions you don’t agree with. Looking just at 4.2 or even 4.4 is not going to give you answers to those questions as you will be stuck with the decision for the long term.

1 Like

If you want things to work like windows, then just use windows. Linux doesn’t work like windows, but somehow you had that expectation. Linux gives you many options often at the expense of ease of use.

No I don’t have that expectations. I have been using Linux since 1992 or 1994 for different tasks, servers, developing, not as the main desktop system… it has is strengths and drawbacks, complexity being one of the later and too developer centric.

Hoping people is going to compile a program and it’s dependencies is not realistic.

Program distribution us not yet well solved, easy and straight forward to the end user when the program you look for us in the repository and you are using the last version, not so easy for programmers who want to reach several flavours.

Anyway it is a great system , I am want to stick with it, as I don’t like the path windows us following

For now database in Ansel is compatible with 4.0 and theodules too, except for filmic7 if you use it, I think.

But you are right that it won’t continue compatible too much time.

In the future I will need two databases to test booths.

For now I don’t need 4.2 features, so …

But your concerns are mine too.

A problem with OpenSource software always, you never know the oath it will follow in the future or when it will be abandoned. I have suffered that several times.

You are not inmune to that with paid software, I had suffered it too.
For example NS has abandoned may projects it had offered for time which I liked and use, and abandoned them abruptly.

I will keep an eye on both projects.
But most of the modules I was using are in Ansel.

But we don’t hope or force people to do that at all. And you ended up not having to compile anything.

I don’t actually understand what you’re complaining about, in the end you got what you wanted, but you had to fiddle a bit. Being a Linux user since the 90s it seems like you should be well aware that that is the trade off.

So Ansel isn’t compatible with darktable 4.0. Compatiblity is binary, it is or it is not.

Some projects have a track record or a history, and other projects have less.

Well yes because Ansel is mostly darktable, no matter what claims the developer makes.

If darktable was such shit, he should’ve started from scratch.

I am not complaining , it seems is just you who want to complain

Just asked how to install an old version of a program, one of the option I was given was to compile the program and libraries.

The other option was flatpak but you have to install the new version and then revert to the old version.

I found it not easy nor intuitive and just commented it was easier in windows that is all.

I had never said darktable is a shit not compare darktable and Ansel.

Just mentioned Ansel because I was asked repeatedly why I was trying to install 4.0 of darktable.

The question was solved and I am not interested in initiating Ansel versus dartable wars.

If you are not willing to compile for yourself, you are fully dependant on what the packagers want to maintain.
That is the case under Linux, but also under MS-windows and MacOS…

Keep in mind that the packager for a distribution is very often not part of the development team for the software. But he does know what libraries and versions are available in the targetted distribution, and which will have to be provided alongside the software package.

So if you want a different version than the available one(s) for your distribution you’ll have to compile it yourself.

If you are lucky, there is a source package of the version you want for your distribution, in that case your package manager can figure out the dependencies.
If not, you are responsable for that as well…

1 Like